View Issue Details

IDProjectCategoryView StatusLast Update
0001332Ham Radio DeluxeEnhancementpublic2017-09-18 00:08
ReporterSupport 
Assigned ToK7ZCZ 
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionfixed 
PlatformNoneOSEmptyOS Version
Product Version 
Target VersionFixed in Version6.4.0.787 
Summary0001332: Logbook Filter Pane Should Be Static Rather Than Dynamic
DescriptionThe filter pane in the logbook is implemented as a dynamic query pane, so every
time you open or close it, the entire logbook is apparently read. Also, the
filter queries are dynamic as well, so it's churning the logbook db with every
change made to data in the filter pane.

This implementation makes little sense. The filter pane should be static. You
should be able to open and close it without churning the logbook db. You should
be able to enter data and choose pull-down options without churning the logbook
db. When you want to run the filter, you should be able to click on an 'Apply'
or similar button to cause the query to be run.
Additional InformationReported by k6mkf
TagsNo tags attached.
ModuleLogbook
Sub-ModuleFunctional
TestingNot Started

Relationships

related to 0002197 assignedK7ZCZ 2 - Next Dev List (Holding Area) Logbook open and close performance is slow 
related to 0002128 closedK7ZCZ Ham Radio Deluxe Logbook filter is difficult to use 

Activities

K7ZCZ

2017-09-07 15:59

viewer   ~0004130

This is a combo platter of issues.

I completely agree with the notion of an Apply button; that's implemented with the fix to 2128.

The issue of taking a while to open is gone; the code doesn't scan or reload the database when the filter window is opened.

The issue of taking a while to close is actually necessary: we have to reset from whatever filtered rows might be shown to the full set of rows when the filter bar is closed. Closing the filter window implicitly closes its effect, so that's by-design. The issue of performance, though ,is noted. The logbook uses an overly granular data structure and that makes building and tearing down even medium-sized logbook lists quite slow. That issue is tracked by 2197.

K7ZCZ

2017-09-07 16:09

viewer   ~0004131

Marking this closed, as the primary issue (Apply button, not timer) is addressed by one of the related bugs. The other fixable problem is represented by a more granular issue, now related to this bug.

g3ucq

2017-09-08 03:10

viewer   ~0004136

A huge improvement. Thanks

g3ucq

2017-09-08 03:55

viewer   ~0004140

Just a thought. Could the ENTER key be used as well as the APPLY button?

K7ZCZ

2017-09-08 10:41

viewer   ~0004145

Maybe some day. While it seems like a simple feature (hit this pushbutton when ENTER is pressed!), the implementation is hampered by the need to manage focus and routing in a complex structure of windows.

In the logbook in this state, the Apply button appears on the filter bar window, which ahs a few other controls in it. The bar is a child of a frame window, which has siblings (the logbook entry list itself), and is parented by the tabbed logbook frame window. That, in turn, is a child of the main frame window of the application itself -- which has more toolbars and panels inside of it.

When ENTER is pressed, which window should be offered the chance to handle it? Routing input isn't a simple problem, since we have to navigate all those windows, the UI state, and so on. It's certainly a solvable problem, but usually requires a pretty involved solution. I think it would be best to open a feature request issue separate from this issue (which is already decomposable into three or four more distinct issues) and address it as we have time and priority in the future.

k2dls

2017-09-17 13:18

viewer   ~0004199

Apply button fixes the issue nicely.

WA9PIE

2017-09-18 00:08

administrator   ~0004232

Closed as part of the 6.4.0.787 release.

Issue History

Date Modified Username Field Change
2013-12-23 21:44 WA9PIE New Issue
2013-12-23 21:44 WA9PIE Status new => assigned
2013-12-23 21:44 WA9PIE Assigned To => Support
2013-12-24 09:30 WA9PIE Project 2 - Next Dev List (Holding Area) => @5@
2013-12-24 22:12 WA9PIE Status assigned => new
2014-01-31 17:25 WA9PIE Release => (select)
2014-01-31 17:25 WA9PIE Module => (select)
2014-01-31 17:25 WA9PIE Sub-Module => (select)
2014-01-31 17:25 WA9PIE Report Build => (select)
2014-01-31 17:25 WA9PIE Assigned To Support =>
2014-01-31 17:25 WA9PIE Status new => confirmed
2014-01-31 17:25 WA9PIE Description Updated View Revisions
2014-02-02 14:51 WA9PIE Summary Logbook Filter Pane Should Be Static Rather Than Dynamic => Bug: Logbook Filter Pane Should Be Static Rather Than Dynamic
2014-02-02 16:39 WA9PIE View Status private => public
2014-08-18 16:03 WA9PIE Summary Bug: Logbook Filter Pane Should Be Static Rather Than Dynamic => Enhancement: Logbook Filter Pane Should Be Static Rather Than Dynamic
2014-08-18 16:04 WA9PIE Project @5@ => @6@
2015-09-17 13:02 WA9PIE Module (select) => Logbook
2015-09-17 13:18 WA9PIE Category Logbook => Enhancement
2015-09-17 13:18 WA9PIE Project @6@ => 1 - Backlog
2015-09-29 17:11 WA9PIE Fix Build => (select)
2015-09-29 17:11 WA9PIE Summary Enhancement: Logbook Filter Pane Should Be Static Rather Than Dynamic => Logbook Filter Pane Should Be Static Rather Than Dynamic
2017-09-03 15:37 K7ZCZ Assigned To => K7ZCZ
2017-09-03 15:37 K7ZCZ Status confirmed => assigned
2017-09-03 15:37 K7ZCZ Project 1 - Backlog => 3 - Current Dev List
2017-09-07 15:59 K7ZCZ Note Added: 0004130
2017-09-07 15:59 K7ZCZ Relationship added related to 0002197
2017-09-07 15:59 K7ZCZ Relationship added related to 0002128
2017-09-07 16:06 K7ZCZ Sub-Module (select) => Functional
2017-09-07 16:06 K7ZCZ Testing => Not Started
2017-09-07 16:09 K7ZCZ Status assigned => resolved
2017-09-07 16:09 K7ZCZ Resolution open => fixed
2017-09-07 16:09 K7ZCZ Note Added: 0004131
2017-09-07 18:18 K7ZCZ Fixed in Version => 6.4.0.784
2017-09-08 03:10 g3ucq Note Added: 0004136
2017-09-08 03:55 g3ucq Note Added: 0004140
2017-09-08 10:41 K7ZCZ Note Added: 0004145
2017-09-11 21:32 K7ZCZ Fixed in Version 6.4.0.784 => 6.4.0.785
2017-09-14 19:23 K7ZCZ Fixed in Version 6.4.0.785 => 6.4.0.787
2017-09-17 13:18 k2dls Note Added: 0004199
2017-09-18 00:06 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2017-09-18 00:08 WA9PIE Note Added: 0004232
2017-09-18 00:08 WA9PIE Status resolved => closed