View Issue Details

IDProjectCategoryView StatusLast Update
0001540Ham Radio DeluxeBugpublic2017-05-22 23:41
ReporterWA9PIE 
Assigned ToWA9PIE 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version3.2.7.315 
Summary0001540: DX Cluster fixes
Descriptiona) Change ""Console"" window to a non-proportional font."

b) In the spreadsheet, the following changes are described in columns D and G.

o Remove 3 fields; add 1 field

o Rename 28 fields; I intentionally have spaces after the "":"" to manipulate the alphabetical sort of these fields.

§ (2 field names are unchanged; total of 34 fields remaining after this change)

o Rename 11 column labels

o Sort the resulting Field list alphabetically by Field name (same as the sorting I have in the spreadsheet)"

c) Revise all the field descriptions based on the spreadsheet (column H)." These should also be “tool-tips” for hovering over the header of a cluster column.

d) For those Fields that now begin with ""Spot"", revise the parsing/mapping of the cluster string for CC11 and AR17 per the columns shown in the spreadsheet (columns I and J). Those that begin with ""DX de"" fit the model described in the ""Simple"" tab. Example also case-by-case in ParsingCases.txt. Leave the ""Z"" on the end of the 4-digit time in all cases."

e) Recode how ""HRD:Country"" (formerly, ""Calc: Country"") works. Rather than trying to do a lookup against the DX Call, please do a lookup against the data that comes from the cluster in ""Spot:DX Country"" using only the prefix provided by the cluster in that field. Resulting data would contain the HRD country name and its prefix. (Presently, “Spot:DX Country” is missing.)

Examples:
CC Cluster may send ""K"". HRD:Country should then display ""United States (K)"".
DXSpider may send ""NJ-New-Jersey-K"". HRD:Country should then display ""United States (K)"".
AR Cluster may send ""K"". HRD:Country should then display ""United States (K)""."
 
f) Change the install defaults for what Fields are shown in the DX Cluster by default. The default fields and order of the fields are shown in the spreadsheet (column A, ""Default)... as Field 1, Field 2... Field 8."

g) Recode what we're sending the cluster during the login script for the differences between CC Cluster/DXSpider and AR Cluster:

""echo #init#"" and ""echo #wwv"" are not valid commands in AR-Cluster (not sure what we need to do with that)"
 
h) Recode for the initial spots sent by AR Cluster (only when connected to AR Cluster).

Initial spots (received through ""sh/dx"") are sent in the ""Simple"" format shown in the spreadsheet ""Simple"" tab. When AR Cluster is detected, parse those initial spots using this format. (This probably gets done as a part of the parsing item above.)"
 
i) Put the WA9PIE-2 cluster node at the top of the list (WA9PIE-2, hrd.wa9pie.net, port 8000)"

j) (Lee, VE7CC reports) There is also a problem with HRD telnet he would like to see fixed. HRD telnet requires almost instant reply to ""keep alives"" or else it disconnects. The reply time needs to be much longer than currently in use; he would like to see at least 60 seconds. And he would like to see at least a couple of minutes between retries if the connects."

k) Update DX Cluster ""Alarms:E-Mail"" format (see text file)"
TagsNo tags attached.
ModuleLogbook
Sub-ModuleDX Cluster
Testing

Relationships

Activities

WA9PIE

2013-12-28 01:40

administrator  

Cluster Changes WA9PIE.xlsx (286,467 bytes)

WA9PIE

2014-01-19 13:29

administrator   ~0000110

As of 1/19, here's what's left:

• Beta team is reporting that Distance and Heading (Az) are not correct.
• We still need room in the Layout dialog box for the field Description. (Make it a bit taller)
• Found a bug in the “Dx de” parsing (search for 6W5SK in the attached TXT file and refer to the attached image).
• We still need N/A in the fields where there is no data (per the image below).
• When connected to an AR Cluster, the Band Filter dropdown in the cluster doesn’t work.
• (Lee, VE7CC reports) There is also a problem with HRD telnet he would like to see fixed. HRD telnet requires almost instant reply to "keep alives" or else it disconnects. The reply time needs to be much longer than currently in use; he would like to see at least 60 seconds. And he would like to see at least a couple of minutes between retries if the connects fail.

WA9PIE

2014-01-19 23:13

administrator   ~0000121

Additionally, the Announcement, WWV, and WCY is only parsing correctly on DX Spider.

WA9PIE

2014-01-19 23:40

administrator   ~0000123

All these are pending the 6.2 release.

WA9PIE

2014-01-29 23:24

administrator   ~0000182

• DX Spider
  o “DX State” isn’t parsing correctly for DX Spider (and likely for CC Cluster; see VR2XMT below). In CC11, “DX State” should be taken directly from the 14th field in the string (zero-based), not by parsing it out of the DX Country field.
• AR Cluster
  o When connected to an AR Cluster, the Band Filter dropdown in the cluster doesn’t work. (This is where the images below show a “HF” dropdown.)
  o We still need N/A in the fields where there is no data (per the image below).
  o Initial Announcements (sh/ann) do not parse. I’m not sure about the subsequent ones. I’m attaching an example.
  o Initial WWV (sh/wwv) do not parse. I’m not sure about the subsequent ones. I’m attaching an example.
• CC Cluster
  o Initial Announcements (“sh/an”) are not parsed correctly. (probably never have been; parsing format for CC Cluster Announcements is different than others)
• All Clusters
  o Presently, when the “Close” button is selected… Logbook sends “Quit” to the console (and probably to the cluster node). We need to change this to “Bye”.
     [Reason: Not all cluster nodes recognize “Quit” as the logoff command. However, all cluster types recognize “Bye”. This prevents people from logging on to the same node for a period of time. So we need to send “Bye” and the telnet session will respond with “Disconnected”.]
  o Beta team is reporting that Distance and Heading (Az) are not correct. You had suggested that we put a tilde (~) in front of Distance and Heading… we may as well add it to Latitude and Longitude also. However, the problem is that there are cases where we’re calculating the distance and heading to the South Pole. I’m not sure if we’re using Grid from the spot… Grid from the country file… Spot State… or what. But we need to come up with a way that is somewhat consistent. If we’re using the spot info for “DX State” or “DX Grid/QRA/Locator”… then we should probably list “N/A” when those fields are blank – rather than calculating to the South Pole.

WA9PIE

2014-02-02 20:18

administrator   ~0000334

Following an alpha build, here's what seems to be left:

New ones (resulting from the changes):

• AR Cluster stops displaying spots after the first “lot” that comes from “sh/dx”
• AR Cluster is back to displaying the AR17 strings as CC11 strings. That makes it impossible to test and likely why the previous item is broken.

•DX Spider
 o Fill DX State with “N/A” when the string has an empty field.

•AR Cluster
 o We still need N/A in the fields where there is no data (per the image below) (as it is when “sh/dx” is used). [Couldn’t test because no spots are coming in.]

•CC Cluster
 o Initial WCY is not parsed (this comes from “sh/wcy”

WA9PIE

2014-02-03 23:42

administrator   ~0000336

This is very close. These items remain:

Latest build; these items remain from #32:

• DX Spider
  o We still need N/A in the fields where there is no data AFTER “sh/dx” (SP State)
  o Initial WCY is not parsed (this comes from “sh/wcy”; console text attached for DX Spider)

• AR Cluster
  o We still need N/A in the fields where there is no data AFTER “sh/dx” (DX State, SP State, DX Grid, & SP Grid)
       This does work properly with the initial “sh/dx” spots.
  o (FYI-Nothing to do with WCY here; AR Cluster doesn’t do WCY)

• CC Cluster
  o Initial WCY is not parsed (this comes from “sh/wcy”; console text attached for CC Cluster)

WA9PIE

2014-02-05 21:53

administrator   ~0000345

Latest build; these items remain from #32:

• DX Spider
  o We still need N/A in the fields where there is no data AFTER “sh/dx” (SP State)

WA9PIE

2014-03-24 23:17

administrator   ~0000371

This was a MASSIVE piece of work. Thanks Erik!

Mike, wa9pie

Issue History

Date Modified Username Field Change
2013-12-28 01:40 WA9PIE New Issue
2013-12-28 01:40 WA9PIE File Added: Cluster Changes WA9PIE.xlsx
2014-01-19 13:29 WA9PIE Note Added: 0000110
2014-01-19 23:13 WA9PIE Note Added: 0000121
2014-01-19 23:40 WA9PIE Status new => acknowledged
2014-01-19 23:40 WA9PIE Note Added: 0000123
2014-01-19 23:42 WA9PIE Status acknowledged => assigned
2014-01-19 23:42 WA9PIE Assigned To => WA9PIE
2014-01-29 23:24 WA9PIE Note Added: 0000182
2014-02-02 15:21 WA9PIE Summary DX Cluster fixes => Bug: DX Cluster fixes
2014-02-02 16:39 WA9PIE View Status private => public
2014-02-02 20:18 WA9PIE Note Added: 0000334
2014-02-03 23:42 WA9PIE Note Added: 0000336
2014-02-03 23:43 WA9PIE Severity minor => major
2014-02-05 21:53 WA9PIE Note Added: 0000345
2014-03-24 23:17 WA9PIE Note Added: 0000371
2014-03-24 23:17 WA9PIE Status assigned => closed
2014-03-24 23:17 WA9PIE Resolution open => fixed
2014-10-08 22:13 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2014-10-08 22:13 WA9PIE Category Logbook => General
2015-09-30 12:02 WA9PIE Proposed Release => TBD
2015-09-30 12:02 WA9PIE Summary Bug: DX Cluster fixes => DX Cluster fixes
2015-09-30 12:02 WA9PIE Description Updated View Revisions
2015-09-30 13:35 WA9PIE Category General => Bug
2016-11-06 21:57 WA9PIE Issue cloned: 0001960
2017-05-22 23:41 WA9PIE Fixed in Version => 3.2.7.315