View Issue Details

IDProjectCategoryView StatusLast Update
0001543Ham Radio DeluxeBugpublic2017-09-18 00:08
ReporterWA9PIE 
Assigned ToWA9PIE 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.4.0.787 
Summary0001543: SRX_string Layout attribute missing
DescriptionIn uploading and adif file from a recent contest into a newly created database I noticed there is no access to srx_string. A number of contests require US stations to transmit the state and DX stations a serial number. Those import properly into the database if you export into xml from the log. When you try to build a contest input form, you can get a serial number field srx but not the srx_string for the alpha. If you are writing cabrillo you are trapped as well.
TagsNo tags attached.
ModuleLogbook
Sub-ModuleContest
Testing Beta Successful

Relationships

related to 0002231 closedK7ZCZ STX_STRING and SRX_STRING values are not being exported properly on ADIF export 

Activities

WA9PIE

2014-05-01 21:53

administrator   ~0000413

Additional user reports:

==========
This has not been solved yet (if I recall the entire issue) I just input a couple of ARRL Field Day exchanges and when I transferred from my contest log to the main log all exchanges similar to "1E UT" were now like "E UT" the "1" was stripped off and placed in the other exchange field. "1E UT" is a string as is "1 ET", just because the number is in the first position does not require the program to move it from the field the user desires it to be in to another field at the whim of the program.

==========
The contest log book data which shows exchange information like 1E UT was split in the ADIF export (both the sent and receive field groups) into <srx:1>1 <srx_string:4>E UT (there are four characters in the SRX_STRING).

After the creation of the full HRD ADIF I manually edited the ADIF file to be <srx_string:5>1E UT, deleted the <srx:1>1 and then the modified file imports correctly into the master log book or in other words the data in the master log now looks like it did in the original contest log. A lot of work, but most of those logs are under 200 QSO's.

ERIK

2014-05-09 16:05

developer   ~0000426

SRX was being derived from SRX_STRING, then SRX_STRING was being deleted. Removed the SRX_STRING deletion.

WA9PIE

2014-08-18 15:04

administrator   ~0000504

Cleaning up closed items already marked "Resolved".

Mike, WA9PIE

WA9PIE

2015-09-30 12:37

administrator   ~0000618

I think this may still be broken.

WA9PIE

2017-06-26 06:45

administrator   ~0003333

I need to confirm that these were actually fixed.

WA9PIE

2017-07-25 20:20

administrator   ~0003741

Here's a forum post that's probably the best description of this problem. We could probably find the operator to get more detail:

https://forums.ham-radio-deluxe.com/forum/hrd-6-x-peer-support-forums/hrd-6-2-logbook/3606-hrd-is-still-broken-for-adif-exports-after-over-4-years?28572-HRD-is-STILL-broken-for-ADIF-exports-after-over-4-years=

K7ZCZ

2017-09-01 16:53

manager   ~0004097

There are no useful repro steps in this issue. As far as I can tell, it's a duplicate of 0002231. Is there some set of repro steps that makes a bug apparent?

WA9PIE

2017-09-01 17:07

administrator   ~0004098

Tested successful

WA9PIE

2017-09-18 00:08

administrator   ~0004230

Closed as part of the 6.4.0.787 release.

Issue History

Date Modified Username Field Change
2014-01-16 19:36 WA9PIE New Issue
2014-02-02 09:58 WA9PIE Summary srx_string Layout attribute missing => Bug: srx_string Layout attribute missing
2014-02-02 09:59 WA9PIE Project @6@ => @5@
2014-02-02 14:55 WA9PIE Status new => confirmed
2014-05-01 21:53 WA9PIE Note Added: 0000413
2014-05-01 21:54 WA9PIE Project @5@ => 3 - Current Dev List
2014-05-01 21:54 WA9PIE Assigned To => ERIK
2014-05-01 21:54 WA9PIE Status confirmed => assigned
2014-05-09 16:05 ERIK Note Added: 0000426
2014-05-09 16:06 ERIK Release 6.1 => 6.2
2014-05-09 16:06 ERIK Status assigned => resolved
2014-05-09 16:06 ERIK Resolution open => fixed
2014-05-27 14:39 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2014-05-27 14:39 WA9PIE Category Logbook => General
2014-08-18 15:04 WA9PIE Note Added: 0000504
2014-08-18 15:04 WA9PIE Status resolved => closed
2015-09-30 12:36 WA9PIE Fix Build TBD => (select)
2015-09-30 12:36 WA9PIE Proposed Release => TBD
2015-09-30 12:36 WA9PIE Summary Bug: srx_string Layout attribute missing => SRX_string Layout attribute missing
2015-09-30 12:37 WA9PIE Note Added: 0000618
2015-09-30 13:35 WA9PIE Category General => Bug
2017-06-19 20:46 WA9PIE Project Ham Radio Deluxe => 3 - Current Dev List
2017-06-26 06:45 WA9PIE Status closed => feedback
2017-06-26 06:45 WA9PIE Note Added: 0003333
2017-07-25 20:20 WA9PIE Note Added: 0003741
2017-07-25 20:20 WA9PIE Status feedback => assigned
2017-09-01 00:17 WA9PIE Relationship added related to 0002231
2017-09-01 16:53 K7ZCZ Status assigned => feedback
2017-09-01 16:53 K7ZCZ Note Added: 0004097
2017-09-01 16:56 K7ZCZ Assigned To ERIK => WA9PIE
2017-09-01 17:07 WA9PIE Testing => Beta Successful
2017-09-01 17:07 WA9PIE Fixed in Version => 6.4.0.782
2017-09-01 17:07 WA9PIE Status feedback => resolved
2017-09-01 17:07 WA9PIE Note Added: 0004098
2017-09-07 18:18 K7ZCZ Fixed in Version 6.4.0.782 => 6.4.0.784
2017-09-11 21:32 K7ZCZ Fixed in Version 6.4.0.784 => 6.4.0.785
2017-09-14 19:23 K7ZCZ Fixed in Version 6.4.0.785 => 6.4.0.787
2017-09-18 00:06 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2017-09-18 00:08 WA9PIE Note Added: 0004230
2017-09-18 00:08 WA9PIE Status resolved => closed