View Issue Details

IDProjectCategoryView StatusLast Update
0001605Ham Radio DeluxeBugpublic2017-05-22 00:05
ReporterWA9PIE 
Assigned ToWA9PIE 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.3.0.448 
Summary0001605: ALE in DM-780 is not using the same callsign lookup as Logbook (missing UCSDB at least)
DescriptionWe found this when we fixed the Lookup Pane issue in Logbook.

The same callsign lookup functions are not being used for DM-780. Calls that are in the UCSDB (like HK0/UA4WHX) are not found and the wrong country is being populated in the Country field in the DM-780 ALE.
TagsNo tags attached.
ModuleDM780
Sub-ModuleALE Window
Testing

Relationships

Activities

WA9PIE

2014-04-05 00:57

administrator   ~0000397

Saw this when we worked on the Logbook's Lookup Pane.

WA9PIE

2014-04-05 23:52

administrator   ~0000398

The UCSDB is now picking up the country for calls in the UCSDB.

However, DM-780 (like Logbook) should not be filling CQ or ITU zones from the default values in the country file.

WA9PIE

2014-04-06 23:51

administrator   ~0000399

I tested an alpha build. It worked.

Mike

WA9PIE

2014-04-10 21:48

administrator   ~0000402

Closing this. But it's not completely right. We'll get it later.

--------------

DM-780 (like Logbook) should be filling CQ or ITU zones from callsign lookup choices. It's not.

WA9PIE

2015-10-13 17:31

administrator   ~0000644

Ron, W3RJW, indicates that his testing shows that this was not fixed.

Re-opening it.

user51

2015-10-13 18:52

 

DM-780 ALE.doc (293,376 bytes)

user51

2015-10-14 06:29

  ~0000646

Last edited: 2015-10-14 11:36

View 3 revisions

Attached file with an example ... not just the ITU and CQ zone issue .... doesn't appear to ever use logbook data in the DM-780 ALE

Have highlighted 6 fields that do not xfer correctly in one direction or the other ... there may be more

If someone is looking at this broad issue I can provide detailed information ...

Please read my complete report ... issue is wider then Mantis title

user51

2015-10-14 08:38

  ~0000647

Why is this a problem::

Say you have correct and complete data for a station in the logbook .. if you work that station on a digital/cw mode (DM-780 ALE), the wrong data gets put into the QSO record(lookup priority not honored), replacing all the carefully added data with QRZ and Countries List data ... Logbook data never used

now when you work the station again from the logbook ALE, all the wrong data gets put back in that QSO record because the lookup priority works in the ALE Logbook window, but now the logbook from the last contact has the wrong data ......

user51

2015-11-16 13:56

  ~0000671

Last edited: 2015-11-16 15:42

View 2 revisions

No change to anything mentioned in attached document ... Version .447

New comparison of data xfer using version .447 - document added

FUBAR

user51

2015-11-16 15:40

 

LB-DM Data xfer.docx (186,711 bytes)

user51

2015-11-18 13:05

  ~0000672

To sum up ......

The lookup in DM-780's ALE should work exactly the way it works in Logbook. Period

user51

2015-12-21 17:16

  ~0000719

Last edited: 2016-07-28 08:42

View 2 revisions

Sinking into black hole ....



Soon to be forgotten ... affects every user of HRD! 7/29/16

WA9PIE

2017-05-21 22:21

administrator   ~0003169

Closed in bulk

Issue History

Date Modified Username Field Change
2014-04-05 00:53 WA9PIE New Issue
2014-04-05 00:57 WA9PIE Note Added: 0000397
2014-04-05 00:57 WA9PIE Assigned To => WA9PIE
2014-04-05 00:57 WA9PIE Status new => confirmed
2014-04-05 01:10 WA9PIE Assigned To WA9PIE => ERIK
2014-04-05 01:10 WA9PIE Status confirmed => assigned
2014-04-05 23:52 WA9PIE Note Added: 0000398
2014-04-06 23:51 WA9PIE Fix Build TBD => post 251
2014-04-06 23:51 WA9PIE Note Added: 0000399
2014-04-06 23:51 WA9PIE Status assigned => closed
2014-04-06 23:51 WA9PIE Resolution open => fixed
2014-04-09 09:19 W4PC Fix Build post 251 => 6.2.255
2014-04-09 09:19 W4PC Status closed => resolved
2014-04-10 21:48 WA9PIE Note Added: 0000402
2014-04-10 21:48 WA9PIE Status resolved => closed
2014-10-08 22:13 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2014-10-08 22:13 WA9PIE Category DM-780 => General
2015-09-30 12:07 WA9PIE Fix Build 6.2.255 => (select)
2015-09-30 12:07 WA9PIE Proposed Release => TBD
2015-09-30 12:07 WA9PIE Summary Bug: ALE in DM-780 is not using the same callsign lookup as Logbook (missing UCSDB at least) => ALE in DM-780 is not using the same callsign lookup as Logbook (missing UCSDB at least)
2015-09-30 13:33 WA9PIE Category General => Bug
2015-10-13 17:30 WA9PIE Project Ham Radio Deluxe => 2 - Next Dev List (Holding Area)
2015-10-13 17:31 WA9PIE Note Added: 0000644
2015-10-13 17:31 WA9PIE Status closed => confirmed
2015-10-13 18:52 user51 File Added: DM-780 ALE.doc
2015-10-14 06:29 user51 Note Added: 0000646
2015-10-14 08:38 user51 Note Added: 0000647
2015-10-14 08:41 user51 Note Edited: 0000646 View Revisions
2015-10-14 11:36 user51 Note Edited: 0000646 View Revisions
2015-11-04 13:45 WA9PIE Reported in Build (ie. 377) 6.2 => all
2015-11-04 13:45 WA9PIE Fixed in Release TBD => 6.2
2015-11-04 13:45 WA9PIE Fixed in Build (ie. 377) (select) => 444
2015-11-16 13:56 user51 Note Added: 0000671
2015-11-16 15:40 user51 File Added: LB-DM Data xfer.docx
2015-11-16 15:42 user51 Note Edited: 0000671 View Revisions
2015-11-18 13:05 user51 Note Added: 0000672
2015-12-21 17:16 user51 Note Added: 0000719
2016-07-28 08:42 user51 Note Edited: 0000719 View Revisions
2017-03-08 10:41 WA9PIE Assigned To ERIK => WA9PIE
2017-05-21 22:07 WA9PIE Project 2 - Next Dev List (Holding Area) => Ham Radio Deluxe
2017-05-21 22:21 WA9PIE Note Added: 0003169
2017-05-21 22:21 WA9PIE Status confirmed => closed
2017-05-22 00:05 WA9PIE Fixed in Version => 6.3.0.448