View Issue Details

IDProjectCategoryView StatusLast Update
0001609Ham Radio DeluxeBugpublic2017-05-24 22:01
Reporteruser19 
Assigned Touser62 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.2.8.324 
Summary0001609: Errors in DM-780 and FSK-45
DescriptionSaw this bug (and I will do a Mantis report on it) while working with a support client. This only happens in FSK-45. FSK-50 and 75 work correctly with both interface/rig combinations. This bug was in .241 as well as .254. Not sure how far back it goes, but I could consistently reproduce this error in these two versions.

At times, I will get what looks like the software trying to open the FSK keying comm port twice. I get an error message it can't open the comm port. Click OK and the error goes away and the message is transmitted.

Next, app will not release the TX line after the Macro message is completed. <stop> does not work imbedded in a Macro and remains grayed out on the toolbar. DM-780 hangs at this point requiring you to force the application closed and reset all hardware (MK-II, Station Master and IC-756 Pro III). The transceiver remains in diddle. If I type a message and use the <stop> or F5 key, it works correctly. This behavior was only noted with the microHam microKeyer II interface. Again, this does not happen in FSK-50 or FSK-75.

The first error with the comm port was present in a system using a Yaesu SCU-17 interface. All ports are Virtual Comm Ports on both systems.
Steps To ReproduceRestart all hardware/applications and it does it again.
TagsNo tags attached.
ModuleDM780
Sub-ModuleData
Testing

Relationships

Activities

W4PC

2014-08-30 15:32

updater   ~0000545

added abort button

user36

2014-09-12 12:25

  ~0000552

Last edited: 2014-09-12 13:00

View 4 revisions

(Problem still exists in build 295)

Additional research:
On a breakout box, the DTR/RTS lines (used to key the transmitter) will usually release if the "Stop" button is pressed before the <stop> command is sent.

("Usually," because occasionally the DTR or RTS lines would remain logic high.)

TX line appeared to toggle correctly with TX data.

Test HW was a standard two-color LED breakout box on an FTDI serial port.

Setup was as a RigBlaster Pro with TX selected to toggle the PTT line.

*** ALSO, RTTY 50/75 baud are AFSK modes ***


-- N6EY

user36

2014-09-12 13:19

  ~0000555

Still exists as of build 295. See notes.

WA9PIE

2017-05-21 22:21

administrator   ~0003178

Closed in bulk

Issue History

Date Modified Username Field Change
2014-04-13 11:35 user19 New Issue
2014-04-13 21:05 WA9PIE Project 3 - Current Dev List => @5@
2014-08-07 13:16 WA9PIE Summary BUG: Errors in DM-780 and FSK-45 => Bug: Errors in DM-780 and FSK-45
2014-08-30 15:32 W4PC Fix Build TBD => 290
2014-08-30 15:32 W4PC Note Added: 0000545
2014-08-30 15:32 W4PC Status new => resolved
2014-08-30 15:32 W4PC Resolution open => fixed
2014-08-30 15:32 W4PC Assigned To => W4PC
2014-08-30 15:35 WA9PIE Project @5@ => 3 - Current Dev List
2014-09-12 12:25 user36 Note Added: 0000552
2014-09-12 12:26 user36 Note Edited: 0000552 View Revisions
2014-09-12 12:27 user36 Note Edited: 0000552 View Revisions
2014-09-12 13:00 user36 Note Edited: 0000552 View Revisions
2014-09-12 13:19 user36 Note Added: 0000555
2014-09-12 13:19 user36 Status resolved => confirmed
2015-09-17 13:34 WA9PIE Category DM-780 => (No Category)
2015-09-17 13:35 WA9PIE Category (No Category) => Bug
2015-09-22 23:34 WA9PIE Fix Build 290 => (select)
2015-09-22 23:34 WA9PIE Proposed Release => TBD
2015-09-22 23:34 WA9PIE Summary Bug: Errors in DM-780 and FSK-45 => Errors in DM-780 and FSK-45
2017-03-08 00:07 WA9PIE Project 3 - Current Dev List => 1 - Backlog
2017-03-10 14:50 WA9PIE Assigned To W4PC => user62
2017-05-21 22:02 WA9PIE Project 1 - Backlog => Ham Radio Deluxe
2017-05-21 22:21 WA9PIE Note Added: 0003178
2017-05-21 22:21 WA9PIE Status confirmed => closed
2017-05-24 22:01 WA9PIE Fixed in Version => 6.2.8.324
2017-05-24 22:01 WA9PIE Reported in Build (ie. 377) 6.2 =>
2017-05-24 22:01 WA9PIE Fixed in Build (ie. 377) (select) =>