View Issue Details

IDProjectCategoryView StatusLast Update
0001616Ham Radio DeluxeBugpublic2017-08-16 16:57
ReporterWA9PIE 
Assigned ToW4PC 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.4.0.638 
Summary0001616: HRD Remote is not working in 6.2 beta
DescriptionTrying to connect to a remote HRD session causes a message that says "Client build is 255, minimum build 1064 required."
Steps To ReproduceInstall the 255 build on both the host and remote computer.
Attempt to make a connection.
Observe "Status" response as shown in attached image.

Additional InformationThis was reported by a user on the HRD Forum site:

http://forums.hrdsoftwarellc.com/showthread.php?28799-Remote-not-Working-with-Build-254-255

TagsNo tags attached.
ModuleRig Control
Sub-ModuleGeneral
Testing

Relationships

Activities

WA9PIE

2014-04-20 15:07

administrator  

HRD Remote Bug.JPG (95,406 bytes)
HRD Remote Bug.JPG (95,406 bytes)

W4PC

2014-04-22 14:36

updater   ~0000409

changed the min build number for threadclasses

WA9PIE

2014-08-18 15:04

administrator   ~0000487

Cleaning up closed items already marked "Resolved".

Mike, WA9PIE

WA9PIE

2017-06-26 06:45

administrator   ~0003330

I need to confirm that these were actually fixed.

k2dls

2017-06-28 10:49

viewer   ~0003388

Fails -- Started server on v655. After a pause, I got the UAC screen and replied yes. Response came back "The service did not respond to the start or control request in a timely fashion." This was replicated several times.

K7ZCZ

2017-06-28 11:52

viewer   ~0003390

This issue doesn't reproduce for me on 655. To diagnose this issue, it would help have some context:

Which version of which OS?
New install or upgrade from previous version?
What's in the C:\ProgramData\HRDLLC directory?
There should be a HRDRemoteSvr.cfg file in there. Can we have a copy of it, please?
Anything logged about the service in the Windows Application Log or System Log?

k2dls

2017-06-28 14:10

viewer   ~0003391

Windows 10 64 bit
Upgrade from 647
HRDRemoteSvr.cfg found in c:\ProgramData\HRDLLC directory, if that is your question. Will have to sanitize a copy if you really need it but this has worked properly in the past.

System log shows event ID 7000 and 7009, text of 7000 matches error provided above. 7009 similar, event timeouts (30,000 ms)

Manual start from services.msc provides same error. Also tried a remove and install.

k2dls

2017-06-28 14:32

viewer   ~0003393

Seems not to be using config file at all anymore, rather HKLM\SOFTWARE\WOW6432Node\Amateur Radio\Ham Radio Deluxe\Remote.

k2dls

2017-06-28 18:11

viewer   ~0003400

I just applied the creator update this afternoon. Now I see that the Remote Server is running. Quite odd. Made no other changes.

k2dls

2017-06-29 11:23

viewer   ~0003427

I tested a client server connection today running 655 at both ends. It failed. Upon investigation, the Windows firewall was blocking the connection because HRDRemoteSvr needed to be added to the allowed program list. Once doing this, I was able to connect. So the install program needs to check for the presence of HRDRemoteSvr in the allowed program list and offer to add it if necessary.

WA9PIE

2017-08-16 16:53

administrator   ~0003993

Is this fixed now?

WA9PIE

2017-08-16 16:57

administrator   ~0003995

Fixed in first release of 2017... records not updated.

Issue History

Date Modified Username Field Change
2014-04-20 15:07 WA9PIE New Issue
2014-04-20 15:07 WA9PIE File Added: HRD Remote Bug.JPG
2014-04-20 15:07 WA9PIE Additional Information Updated View Revisions
2014-04-20 15:07 WA9PIE Assigned To => W4PC
2014-04-20 15:07 WA9PIE Status new => assigned
2014-04-22 14:36 W4PC Fix Build TBD => 6.2.256
2014-04-22 14:36 W4PC Note Added: 0000409
2014-04-22 14:36 W4PC Status assigned => resolved
2014-04-22 14:36 W4PC Resolution open => fixed
2014-05-27 14:39 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2014-05-27 14:39 WA9PIE Category Rig Control => General
2014-08-18 15:04 WA9PIE Note Added: 0000487
2014-08-18 15:04 WA9PIE Status resolved => closed
2015-09-30 12:45 WA9PIE Fix Build 6.2.256 => (select)
2015-09-30 12:45 WA9PIE Proposed Release => TBD
2015-09-30 12:45 WA9PIE Summary Bug: HRD Remote is not working in 6.2 beta => HRD Remote is not working in 6.2 beta
2015-09-30 13:34 WA9PIE Category General => Bug
2017-06-19 21:13 WA9PIE Project Ham Radio Deluxe => 3 - Current Dev List
2017-06-26 06:45 WA9PIE Status closed => feedback
2017-06-26 06:45 WA9PIE Note Added: 0003330
2017-06-28 10:49 k2dls Note Added: 0003388
2017-06-28 11:52 K7ZCZ Note Added: 0003390
2017-06-28 14:10 k2dls Note Added: 0003391
2017-06-28 14:32 k2dls Note Added: 0003393
2017-06-28 18:11 k2dls Note Added: 0003400
2017-06-29 11:23 k2dls Note Added: 0003427
2017-08-16 16:53 WA9PIE Note Added: 0003993
2017-08-16 16:53 WA9PIE Status feedback => assigned
2017-08-16 16:55 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2017-08-16 16:56 WA9PIE Fixed in Version => 6.4.0.638
2017-08-16 16:57 WA9PIE Note Added: 0003995
2017-08-16 16:57 WA9PIE Status assigned => closed