View Issue Details

IDProjectCategoryView StatusLast Update
0001681Ham Radio Deluxe[All Projects] Generalpublic2017-05-24 21:56
ReporterWA9PIE 
Assigned ToW4PC 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.2.8.323 
Summary0001681: License keys being hidden or not being accepted
DescriptionTicket #991971

I reformatted my hard drive due to other performance issues (NOT virus/malware issues).

Reinstalled HRD first using version 6.2.4.625.... input license key and HRD reports license is expiring soon, closes and will not reopen.

Uninstalled HRD and cleared registry of all HRD keys I can find etc. deleted all directories related to HRD to include the AppData folder reference.

Reinstalled using original starting version 6.1.4 and received same result.

There is no trail available. License states is good until 08-09-2014 yet when I click continue, HRD closes and does nothing else.

My license is valid for at least 11 more months from this date as I got it just about 1 month ago.
Steps To ReproduceAgain.. to summarize everything I did and you offered in order so it is clear and consise for your additional troubleshooting for the issues you have identified.


1. Reformatted Laptop to a clean WINDOWS 7 Ultimate
2. Installed version 6.2.4.625.... input received license key and HRD reports license is expiring soon, showing an expiration of 09 Aug 2014.
3. This cannot be true as activation was just purchased less then 30 days prior so should have been valid for 12 months (11 months remaining).
1. HRD allowed no trail period showing the trail license had expired on 19 July 2014. (Assuming my call sign on the license server reported it as expired).
2. HRD, upon having no valid key shut down and would not run.
4. Completely uninstalled version 6.2.4.625 deleting all registry keys and the related AppData folder as well as folder in Program Files (x86) directory.
5. Installed v6.1.4.189 which was the original version I started with and had originally licensed 30 days prior.
1. HRD allowed no trail period showing the trail license had expired on 19 July 2014.
2. HRD, upon having no valid key shut down and would not run
6. Went to HRD site and reviewed forum and support pages.
1. Reinstalled v 6.2.4.625 after fully deleting and tried to run with NO key, Was not successful and no trail period was offered.
2. Attempted to get key to validate while in SAFE MODE with networking. Same results.
3. Attempted to get key to validate while in normal mode with NO internet connection. Same result.
4. Each time, HRD reported key was about to expire (as noted above) then shut down fully.
5. No trail was offered at anytime.
7. Added all HRD suite programs to Windows FIREWALL exception list to allow them access to the internet thinking it may not be getting to the license server due to the firewall blocking it.
8. Emailed support at support@HRDSOFTWARELLC.com multiple times and every email was returned bounced.
9. Attempted to call telephone number for support - phone never rang, just beeped and immediately disconnected.
10. Created ticket #991971
11. Received 1st reply from WA9PIE advising the following:
1. Verify no other instances of HRD were installed and if so remove.
2. Supplied, what he thought was my activation key.
12. Responded to WA9PIE that license he supplied was already expired and was valid for only 30 days.
13. After uninstalling v6.1.4.189 and clearing all registry keys and folders renstalled version 6.2.4.625. input received expired license key anyways, just in case.
1. HRD allowed no trail period again showing the trail license had expired on 19 July 2014.
2. HRD, advised key expired on 09 Aug 2014, shut down and would not run.
14. Received another reply by WA9PIE advising he had issued a new key with same expiration date as prior valid issued activation key.
15. Opened HRD to try newly issued key, HRD activated and begin working as expected while still under originally issued key. The newly issued key was NEVER installed.
16. Advised WA9PIE that the originally issued activation key finally activated HRD, the suite began working and the new key he had just issued issued was not used and would not be used if not required.
Unknown why originally issued activation key would not validate on a virgin loaded machine. No software has been installed on machine except the HRD suite. Over 24 hours the key would not activate, then without warning or notice it activated. Computer was and had always been attached to the Internet via a LAN cord, not wirelessly, except as noted above. Windows had been updated fully until no further updates were available then Windows update checking has been turned fully turned off and shall remain so, before HRD was initially installed.

I hope this helps you in identifying any problems or assists in resolving identified problems. This is an exact account of the order and steps taken by myself and by WA9PIE. If any further question please feel free to email me atjohn@k3jae.com - Thanks.
Additional InformationIf this guy is this good at writing steps, we should add him as a tester.

*** APPLIES TOP ALL MODULES ***
TagsNo tags attached.
ModuleAll (Installer)
Sub-ModuleGeneral
Testing

Relationships

Activities

WA9PIE

2017-05-21 22:21

administrator   ~0003165

Closed in bulk

Issue History

Date Modified Username Field Change
2014-08-03 12:19 WA9PIE New Issue
2014-08-03 12:19 WA9PIE Assigned To => W4PC
2014-08-03 12:19 WA9PIE Status new => assigned
2014-08-07 14:55 WA9PIE Summary Bug: License keys being hidden or not being accepted (osTicket #991971) => Bug: License keys being hidden or not being accepted
2014-08-07 14:55 WA9PIE Description Updated View Revisions
2014-08-07 14:58 W4PC Assigned To W4PC => ERIK
2014-08-11 20:12 user36 Additional Information Updated View Revisions
2014-08-11 20:13 user36 Module DM780 => All
2014-08-12 16:55 user36 Project @5@ => 3 - Current Dev List
2014-08-12 16:56 user36 Proposed Release => 6.2.8
2014-08-12 19:41 user36 Priority normal => high
2015-09-17 13:34 WA9PIE Category General => (No Category)
2015-09-17 13:35 WA9PIE Category (No Category) => Bug
2015-09-22 23:30 WA9PIE Fix Build TBD => (select)
2015-09-22 23:30 WA9PIE Module All => (select)
2015-09-22 23:30 WA9PIE Report Build 6.2.3.271 => (select)
2015-09-22 23:30 WA9PIE Proposed Release 6.2.8 => (select)
2015-09-22 23:30 WA9PIE Summary Bug: License keys being hidden or not being accepted => License keys being hidden or not being accepted
2015-09-30 13:16 WA9PIE Module (select) => All (Installer)
2017-03-08 00:07 WA9PIE Project 3 - Current Dev List => 1 - Backlog
2017-03-08 10:40 WA9PIE Assigned To ERIK => WA9PIE
2017-03-10 14:54 WA9PIE Project 1 - Backlog => @12@
2017-03-10 14:54 WA9PIE Category Bug => General
2017-03-10 14:55 WA9PIE Assigned To WA9PIE => W4PC
2017-05-21 22:15 WA9PIE Project @12@ => Ham Radio Deluxe
2017-05-21 22:18 WA9PIE Status assigned => resolved
2017-05-21 22:18 WA9PIE Resolution open => fixed
2017-05-21 22:21 WA9PIE Note Added: 0003165
2017-05-21 22:21 WA9PIE Status resolved => closed
2017-05-24 21:56 WA9PIE Fixed in Version => 6.2.8.323
2017-05-24 21:56 WA9PIE Reported in Build (ie. 377) (select) =>
2017-05-24 21:56 WA9PIE Fixed in Build (ie. 377) (select) =>