View Issue Details

IDProjectCategoryView StatusLast Update
0001806Ham Radio DeluxeBugpublic2017-05-22 00:05
ReporterKB3NPH 
Assigned ToWA9PIE 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.3.0.448 
Summary0001806: LoTW download not updating the log
DescriptionPhone contact with remote into his system.

Select download from LoTW and it does NOT automatically download confirmed QSOs. Pulled an ADIF of confirmed QSOs from customer's LoTW account and imported into HRD and it updated 80+ matches including new ones he was looking for.

Additional InformationThe file actually IS downloading. It's just not updating the log that has the QSOs in it.
TagsNo tags attached.
ModuleLogbook
Sub-ModuleAwards
Testing

Relationships

Activities

WA9PIE

2015-10-22 23:51

administrator   ~0000661

My gut feeling (not an assumption, but based on what I've seen) is this:

Because the migration builds create a SECOND "My Logbook" log... HRD is getting confused during the download and attempt to apply to this new (empty) "My Logbook" log. Because the new log is empty, the logfile will show something like "0/0 records updated" or "0/0 records loaded in xx seconds". It shows "0/0" because the log it's attempting to load them to is empty.

I raised this point before we released the migration build because I saw it in testing.

The larger problem with this is... now that the migration build has created this extra (empty) "My Logbook" log, it will be very difficult to un-do... though new builds can stop doing this on a go-forward basis.

KB3NPH

2015-10-27 11:13

administrator   ~0000666

Received another phone call today 10/27/2015, about this same issue. Customer is able to upload to LoTW with no issues, however, when he tries to download from within HRD it fails to download and match any records. If customer does an ADIF download directly from his account on the web and imports it into the HRD logbook using the LOTW import feature, it updates the records as it should.

Tim (KB3NPH)

user19

2015-11-05 00:04

  ~0000669

FWIW, this may be fixed in V .444. I was able to delete the My Logbook DB in both ODBC and using Manager and no longer have the My Logbook DB or the Modify DB.

Might want to ask other Betas to test as well.

Jim...

WA9PIE

2016-12-03 10:50

administrator   ~0003019

I can't replicate this problem. What's in the dialog box when he completes the download? It should tell him that no records match. I'd like to see that.

WA9PIE

2017-03-05 21:01

administrator   ~0003103

Unable to replicate. Assumed fixed.

Issue History

Date Modified Username Field Change
2015-10-20 13:23 KB3NPH New Issue
2015-10-22 23:51 WA9PIE Note Added: 0000661
2015-10-22 23:53 WA9PIE Summary LoTW not downloading => LoTW download not updating the log
2015-10-22 23:53 WA9PIE Additional Information Updated View Revisions
2015-10-27 11:13 KB3NPH Note Added: 0000666
2015-11-05 00:04 user19 Fixed in Release TBD => 6.3
2015-11-05 00:04 user19 Fixed in Build (ie. 377) (select) => 444
2015-11-05 00:04 user19 Note Added: 0000669
2016-12-03 10:50 WA9PIE Note Added: 0003019
2017-03-05 21:01 WA9PIE Assigned To => WA9PIE
2017-03-05 21:01 WA9PIE Status new => closed
2017-03-05 21:01 WA9PIE Resolution open => fixed
2017-03-05 21:01 WA9PIE Note Added: 0003103
2017-03-05 22:16 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2017-05-22 00:05 WA9PIE Fixed in Version => 6.3.0.448