View Issue Details

IDProjectCategoryView StatusLast Update
0001818Ham Radio DeluxeEnhancementpublic2017-08-05 18:58
Reporteruser47 
Assigned ToK7ZCZ 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.4.0.659 
Summary0001818: ALE Logbook Comments - LF wanted
DescriptionQ1. In the 'Comments' field, there is no automatic line 'return' at the edge of the box. This is so frustrating when entering a longer comment. Could it not be programmed into the field?
Q2. Again - in the 'Comments' field. If I laboriously enter my own line returns, so that all the info can be seen, if I then modify the record, e.g. to amend a signal report, then "F7" to save the alteration, all those line returns have been deleted!!!
Steps To ReproduceType a comment , press shift Enter at the end of each line e.g.

test
test
test

Save log entry.. re-open log entry.. comment now shows testtesttest
TagsNo tags attached.
ModuleLogbook
Sub-ModuleALE Window
Testing Beta Successful

Relationships

Activities

user47

2015-11-15 11:13

  ~0000670

Ticket #321109:

K7ZCZ

2017-06-03 21:07

manager   ~0003188

The edit control in question has ES_MULTILINE, which is why it can accept an ENTER key press and show the multiple lines in the comment.

I can repro the problem this user reports, so I'll have to dig in a bit more to see what's really happening with the newlines. Code somewhere along the line must be stripping out the newlines, and that's probably because of the XML data exchange that's going on with these forms. If that's true, the fix might be challenging ....

K7ZCZ

2017-06-17 18:06

manager   ~0003215

I have a fix coded

K7ZCZ

2017-06-17 18:11

manager   ~0003216

https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/3507

K7ZCZ

2017-06-20 00:41

manager   ~0003226

I have verified this is fixed in 652

WA9PIE

2017-06-21 20:59

administrator   ~0003237

Status changed to enable update to "Fixed in Version"

WA9PIE

2017-06-21 22:24

administrator   ~0003251

We'll need to leave issues "Assigned" until verified... then change to "Resolved"

I'll document this in process.

w4ase

2017-06-24 08:01

viewer   ~0003292

Looks like this is fix as I understand what the problem was

WA9PIE

2017-06-25 21:32

administrator   ~0003303

This is working as desired.

HOWEVER, this goes hand-in-hand with this one:
https://bugs.hrdsoftwarellc.com/view.php?id=451

WA9PIE

2017-06-25 21:34

administrator   ~0003304

Confirmed fixed. Ran through the steps and received the desired result.

w4elp

2017-06-26 06:05

viewer   ~0003324

v653: NOT fixed. Logbook saves the manually-typed LF ok, but I think the original intent of this item was to have auto word-wrap in the Comment field box. Still no word wrap unless you manually use ENTER to insert a LF.

K7ZCZ

2017-06-26 17:24

manager   ~0003335

I think it's abundantly clear that word-wrap was not the intent of this issue. Word-wrap is not exercised by the repro case, and words like "automatic" and "long line" don't appear in the description. Automatic word-wrap is automatic, and doesn't require entering a newline, which this issue specifically prescribes.

We're tracking a concern that sounds more like auto-wrap your concern separately and specifically in issue 0451. I hope you'll follow that bag and add clarifying comments to it if you don't believe it is what we should be fixing.

w4elp

2017-06-26 19:07

viewer   ~0003336

Note that Q1 in the description above does mention "automatic". I took this to mean automatic. The condition described in Q2 this issue is fixed - manually entered LF's are retained. I was not aware of issue 0451.

K7ZCZ

2017-06-27 12:18

manager   ~0003340

Word-wrap is covered specifically by issue 0451. We've used this issue to address the storage of manually-entered line breaks, and that issue has been fixed.

WA9PIE

2017-07-04 23:30

administrator   ~0003481

Published in the 658 release.

WA9PIE

2017-07-05 00:00

administrator   ~0003516

Waiting to close them until a final item is tested.

WA9PIE

2017-07-05 19:39

administrator   ~0003553

These were all part of the 659 release.

Issue History

Date Modified Username Field Change
2015-11-15 11:11 user47 New Issue
2015-11-15 11:13 user47 Note Added: 0000670
2017-05-23 15:23 WA9PIE Severity minor => feature
2017-06-03 21:07 K7ZCZ Note Added: 0003188
2017-06-03 21:08 K7ZCZ Assigned To => K7ZCZ
2017-06-03 21:08 K7ZCZ Status new => assigned
2017-06-17 18:06 K7ZCZ Note Added: 0003215
2017-06-17 18:06 K7ZCZ Project 2 - Next Dev List (Holding Area) => 3 - Current Dev List
2017-06-17 18:11 K7ZCZ Note Added: 0003216
2017-06-20 00:41 K7ZCZ Status assigned => resolved
2017-06-20 00:41 K7ZCZ Resolution open => fixed
2017-06-20 00:41 K7ZCZ Fixed in Version => 6.4.0.652
2017-06-20 00:41 K7ZCZ Note Added: 0003226
2017-06-21 20:59 WA9PIE Status resolved => assigned
2017-06-21 20:59 WA9PIE Note Added: 0003237
2017-06-21 22:04 K7ZCZ Status assigned => resolved
2017-06-21 22:24 WA9PIE Status resolved => assigned
2017-06-21 22:24 WA9PIE Note Added: 0003251
2017-06-24 08:01 w4ase Note Added: 0003292
2017-06-25 21:32 WA9PIE Note Added: 0003303
2017-06-25 21:34 WA9PIE Status assigned => resolved
2017-06-25 21:34 WA9PIE Note Added: 0003304
2017-06-25 22:46 WA9PIE Testing => Beta Passed
2017-06-26 06:05 w4elp Note Added: 0003324
2017-06-26 17:24 K7ZCZ Note Added: 0003335
2017-06-26 19:07 w4elp Note Added: 0003336
2017-06-27 12:18 K7ZCZ Note Added: 0003340
2017-07-01 08:23 WA9PIE Target Version => 6.4.0.652
2017-07-01 08:23 WA9PIE Fixed in Version 6.4.0.652 => 6.4.0.657
2017-07-04 23:17 WA9PIE Fixed in Version 6.4.0.657 => 6.4.0.658
2017-07-04 23:30 WA9PIE Note Added: 0003481
2017-07-04 23:30 WA9PIE Status resolved => closed
2017-07-04 23:30 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2017-07-04 23:58 WA9PIE Project Ham Radio Deluxe => 3 - Current Dev List
2017-07-05 00:00 WA9PIE Status closed => resolved
2017-07-05 00:00 WA9PIE Note Added: 0003516
2017-07-05 19:37 WA9PIE Fixed in Version 6.4.0.658 => 6.4.0.659
2017-07-05 19:39 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2017-07-05 19:39 WA9PIE Note Added: 0003553
2017-07-05 19:39 WA9PIE Status resolved => closed
2017-07-09 18:59 WA9PIE Testing => Beta Successful
2017-08-05 18:58 WA9PIE Target Version 6.4.0.652 =>