View Issue Details

IDProjectCategoryView StatusLast Update
0001821Ham Radio DeluxeBugpublic2017-05-21 23:46
ReporterKB3NPH 
Assigned Touser47 
PriorityhighSeveritymajorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.3.0.472 
Summary0001821: MSCOMM32 component no longer supported
Descriptionhttp://tickets.hrdsoftwarellc.com/scp/tickets.php?id=3549

Radio Mfgr.:Yaesu
Radio Model:FT-2000
Windows Version:Win 10 64-bit
HRD Version: 6.3.0.440
Yaesu G-1000dxc + EA4TX rotor controller


Microsoft do not support MSCOMM32 any more which the EA4TX requires to function correctly.
EA4TX has now used COMM32 in Eltima control software which when a Virtual COM port is assigned HRD doesn't see it. Therefore the Rotor software in HRD will not function. Can you liase with EA4TX Pablo to establish what can be done in HRD to enable 2700 users potentially updateing to Win10 to be able to use the Rotor feature in HRD. Pablo is www.ea4tx.com.

73 de Mike G3PGA

Excerpt from EA4TX:-
MSCOMM32 is a Microsoft module but unfortunately Windows 10 don’t support this component. Sincerely I cannot understand the reason since this ActiveX has worked Ok with previous O.S. as Windows 7 or 8.1 but Microsoft has decided not to support it anymore.
During last weeks I have been looking for a solution and today we can announce that a new ARSVCOM V6.5 was released with a new ActiveX that is supported and works fine in Windows 10. This new ActiveX is not free or cheap, but it is the only solution that I could find
MSCOMM32 component has been very popular for developers so it’s possible you will detect that some more program that uses a communication port will not work under Windows 10.

TagsNo tags attached.
ModuleRotator
Sub-ModuleInterfacing
Testing

Relationships

Activities

user47

2016-01-25 04:22

  ~0000731

Rotor com port enumeration changed, - may need revisit - unable to test inhouse.

Issue History

Date Modified Username Field Change
2015-11-16 05:45 KB3NPH New Issue
2016-01-25 04:22 user47 Fixed in Build (ie. 377) => 472
2016-01-25 04:22 user47 Note Added: 0000731
2016-01-25 04:22 user47 Status new => closed
2016-01-25 04:22 user47 Assigned To => user47
2016-01-25 04:22 user47 Resolution open => fixed
2017-03-08 19:02 WA9PIE Project 2 - Next Dev List (Holding Area) => Ham Radio Deluxe
2017-05-21 23:46 WA9PIE Fixed in Version => 6.3.0.472
2017-05-21 23:46 WA9PIE Fixed in Build (ie. 377) 472 =>