View Issue Details

IDProjectCategoryView StatusLast Update
0001879Ham Radio DeluxeEnhancementpublic2018-04-09 14:37
Reporteruser47 
Assigned ToK7ZCZ 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.4.0.806 
Summary0001879: HRDlog.net issues
Description1, ensure HRD can delete and/or update a contact in HRDlog.net - this does not work at the moment.
2, Add additioanl upload field - add in the comment field.

Steps To Reproduceadd contact, try to delete it or change something - the logfile in hrd shows an error - missing data

Additional Informationsee hrdlog.net specifications -\Dropbox\HRD alpha builds\6.2 alpha\HRDLognet spec

 1. ADIFKey and ADIFData are incomplete
====================
2014-06-21 00:05:04
OE5WRO HamRadioDeluxe/6.2
Cmd: DELETE
ADIFKey: <QSO_DATE:8>20140620 <CALL:6>RA3DIP <BAND:3>20m <FREQ:9>14.070000 <MODE:5>PSK31 <RST_SENT:3>599 <RST_RCVD:3>599 <STATION_CALLSIGN:6>OE5WRO <GRIDSQUARE:6>KO85ou <DXCC:2>15 <DISTANCE:8>1736.372 <EOR>
Error: A key should contain at least: Call, QSO_Date, Time_On
====================
2014-06-21 00:05:05
OE5WRO HamRadioDeluxe/6.2
ADIFData: <CALL:6>RA3DIP <BAND:3>20m <FREQ:9>14.070000 <MODE:5>PSK31 <RST_SENT:3>599 <RST_RCVD:3>599 <STATION_CALLSIGN:6>OE5WRO <GRIDSQUARE:6>KO85ou <DXCC:2>15 <DISTANCE:8>1736.372 <QSL_SENT:1>N <QSL_RCVD:1>N <EOR>
Error: Missing QSO_Date Time_On A record should contain at least: Call, QSO_Date, Time_On, Band, Mode
 
 
2. ADIFKey and ADIFData are empty
====================
2014-06-20 05:02:50
WA9PIJ HamRadioDeluxe/6.2
Cmd: DELETE
ADIFKey: <EOR>
Error: A key should contain at least: Call, QSO_Date, Time_On
====================
2014-06-20 05:02:50
WA9PIJ HamRadioDeluxe/6.2
ADIFData: <EOR>
Error: Missing Call QSO_Date Time_On Band Mode A record should contain at least: Call, QSO_Date, Time_On, Band, Mode
 
 
3. ADIFKey is empty and ADIFData contains only QSL_RCVD (the field has been modified?)
====================
2014-06-19 04:51:09
k7kdx HamRadioDeluxe/6.2
Cmd: DELETE
ADIFKey: <EOR>
Error: A key should contain at least: Call, QSO_Date, Time_On
====================
2014-06-19 04:51:10
k7kdx HamRadioDeluxe/6.2
ADIFData: <QSL_RCVD:1>Y <EOR>
Error: Missing Call QSO_Date Time_On Band Mode A record should contain at least: Call, QSO_Date, Time_On, Band, Mode
 

 
TagsNo tags attached.
ModuleLogbook
Sub-ModuleHRDLog.net
Testing Beta Successful

Relationships

related to 0002595 closedK7ZCZ The data Logbook sends to HRDLOG.net is not complete (field QSO_Date and Time_On are missing) 

Activities

K7ZCZ

2018-03-24 08:21

manager   ~0004556

as far as I can tell, this is a duplicate of 2595

vk2byi

2018-04-04 02:27

viewer   ~0004657

Refer to my notes on 0002595 for my test case results. Fixed

PD9FER

2018-04-04 11:05

viewer   ~0004675

Fixed

Issue History

Date Modified Username Field Change
2016-02-24 08:03 user47 New Issue
2017-05-23 15:23 WA9PIE Severity minor => feature
2017-08-16 16:50 WA9PIE View Status private => public
2018-03-17 11:39 K7ZCZ Relationship added related to 0002595
2018-03-24 08:21 K7ZCZ Assigned To => K7ZCZ
2018-03-24 08:21 K7ZCZ Status new => resolved
2018-03-24 08:21 K7ZCZ Resolution open => fixed
2018-03-24 08:21 K7ZCZ Testing => Not Started
2018-03-24 08:21 K7ZCZ Note Added: 0004556
2018-04-02 10:44 K7ZCZ Project 2 - Next Dev List (Holding Area) => 3 - Current Dev List
2018-04-02 10:45 K7ZCZ Fixed in Version => 6.4.0.798
2018-04-04 02:27 vk2byi Note Added: 0004657
2018-04-04 11:05 PD9FER Note Added: 0004675
2018-04-04 14:39 WA9PIE Status resolved => closed
2018-04-04 14:39 WA9PIE Testing Not Started => Beta Successful
2018-04-07 19:23 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2018-04-07 19:25 WA9PIE Fixed in Version 6.4.0.798 => 6.4.0.805
2018-04-09 14:37 WA9PIE Fixed in Version 6.4.0.805 => 6.4.0.806