View Issue Details

IDProjectCategoryView StatusLast Update
0001889Ham Radio DeluxeBugpublic2017-05-21 23:54
ReporterWA9PIE 
Assigned ToW4PC 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.4.0.638 
Summary0001889: Callsign lookup is not properly populating locator field when using TAB (works by clicking QRZ button)
DescriptionWhen the callsign lookup runs after entering a call and pressing the TAB key, the grid is taken from the country list lat/long, rather than from the data returned from higher priority lookup sources.

(However, it DOES work correctly when clicking the QRZ button instead of the TAB.)

I strongly suspect this is a problem for some other fields as well. I'll look for those.)
Steps To ReproduceFor callsign lookup options, select the following order:
1. Logbook
2. QRZ.com Subscription
3. Country List

Open ALE
Put TX7EU in the callsign field and press TAB
The locator field is incorrectly filled with CI00cx

You can use the callsign lookup test function to find that BI91we is what is returned from QRZ.
Additional InformationIt's clear that the lookup that happens with the TAB key ignores higher priority lookup sources and uses the coordinates for Marquesas Is. in the Country List to calculate the grid (using those coordinates in the Country List actually would return CI00cx). [The coordinates in the country list for Marquesas Is. are not on land, but are in the center of a group of islands. Nothing wrong with that approach. We use it elsewhere. But the problem is that the lookup isn't working properly.]

Further, there was a change request that was completed some time ago that was intended to cause the same callsign lookup to happen for the QRZ button that happens with the TAB key. In other words... both of these actions should use the same lookup function to return the results.

The result of this problem is that folks have populated invalid data in their log for a rather rare DX Field (CI).
TagsNo tags attached.
ModuleLogbook
Sub-ModuleCall lookup
Testing

Relationships

Activities

WA9PIE

2017-03-05 16:33

administrator   ~0003084

Tested/verified fixed.

Issue History

Date Modified Username Field Change
2016-03-19 11:48 WA9PIE New Issue
2016-03-19 11:49 WA9PIE Project Ham Radio Deluxe => 2 - Next Dev List (Holding Area)
2016-03-19 11:49 WA9PIE Assigned To => W4PC
2016-03-19 11:49 WA9PIE Status new => assigned
2016-03-19 11:50 WA9PIE Description Updated View Revisions
2016-03-19 12:43 WA9PIE Description Updated View Revisions
2016-03-19 12:43 WA9PIE Steps to Reproduce Updated View Revisions
2016-03-19 12:43 WA9PIE Additional Information Updated View Revisions
2017-03-05 16:33 WA9PIE Status assigned => closed
2017-03-05 16:33 WA9PIE Resolution open => fixed
2017-03-05 16:33 WA9PIE Fixed in Release TBD => 6.4
2017-03-05 16:33 WA9PIE Fixed in Build (ie. 377) => 633
2017-03-05 16:33 WA9PIE Note Added: 0003084
2017-03-05 22:16 WA9PIE Project 2 - Next Dev List (Holding Area) => Ham Radio Deluxe
2017-05-21 23:54 WA9PIE Fixed in Version => 6.4.0.638
2017-05-21 23:54 WA9PIE Fixed in Build (ie. 377) 633 =>