View Issue Details

IDProjectCategoryView StatusLast Update
00019813 - Current Dev ListBugpublic2018-03-14 09:15
Assigned ToWA9PIE 
Status assignedResolutionnot fixable 
Product Version 
Target VersionFixed in Version 
Summary0001981: Google Earth will not open from Satellite Tracker
DescriptionThe Google Earth software will not start when the icon is clicked in the Satellite Tracker toolbar.
TagsNo tags attached.
ModuleSatellite Tracking
Testing Beta Failed


has duplicate 0001910 closedK7ZCZ 4 - Closed w/o Action Google Earth will not start from within Sat Tracker 
related to 0002132 resolvedK7ZCZ 1 - Backlog Lookup Google Earth 



2017-06-23 10:04

manager   ~0003270

Looks like Google has withdrawn support for the Google Earth SDK:

Mike, should we remove Google Earth from the product? Is there a replacement, or is fancy mapping just gone?


2017-06-23 10:21

administrator   ~0003271

This is a 2014 story. Google eventually retracted that position and has continued Google Earth. In fact, they just released Google Earth v9 on 18 April 2017. I don't know if it's the same kind of app or not.

I haven't tried launching Google Earth from Sat Track lately. But I do recall that - after Google did some upgrade to it, you had to open Google Earth first... and then when you selected Google Earth within Sat Track, it tracked as normal.


2017-06-23 11:46

manager   ~0003272

On my development machine, I installed Google Earth manually. I had to, in order to build (compile) the code.
I've started Google Earth then stopped it. I still can't launch Google Earth from the Satellite Tracker.

On my VM, Google Earth doesn't appear to be installed -- I can't see a way to run it as an application from the Start menu. Is setup meant to install Google Earth as an app so that users are able to start it and shut it down? I dont think it is doing so. Or are customers meant to do that manually?

The only mention I see of "Google Earth" in the user's meanual is that it is supported from Satellite Tracker. But the only user's manual I can find is from version 6.2. Have things changed since then?

When I try to launch Google Earth, the error I see in the debugegr is "Class not registered". The code is trying to create a given class from the Google SDK with OLE. The message means that either the class isn't [correctly] installed, or the program is asking for the wrong class ID.

It's possible that Google has updated the ID of the class across versions, which is fixable by us getting a new SDK. But the only source I find for an SDK leads to that announcement that Google has dropped support for Google Earth:


2018-03-01 04:16

updater   ~0004333

Google Earth not opening in .791 for me


2018-03-11 12:14

manager   ~0004471

I've got this shelved change list to remove the use of the unsupported COM interface to Google Earth Desktop from the Logbook. This doesn't fix this issue, but it's a step towards cleaning up the dependency.


2018-03-11 12:42

manager   ~0004472

It looks like the Satellite Tracker is meant to use the COM interface to Google Earth Desktop to draw the satellite. It will pass an azimuth and elevation, and let the user adjust the camera for viewing hte satellite against the earth in the background.

Because Google no longer supports the COM interface to Google Earth desktop, I don't believe there's a way to dynamically control the application. The symptom reported in this bug is that Google Earth doesn't open; that's because we CoCreate the COM object and it fails:

    HRESULT hr = CoCreateInstance(EARTHLib::CLSID_ApplicationGE,

with REGDB_E_CLASSNOTREG. That error message means either the class we're trying to create (a local server for the Google Earth application interface implementation) isn't available on the machine, or we're asking for the wrong interface.

The interface definition comes from an old version of the Google Earth type library rescued from an older installation of the Google Earth desktop product. That version of the product is no longer supported by Google and can't be downloaded or installed. No new programmatic interface information is available, as far as I can tell, because Google no longer supports the COM interface.

At this point, all we can do is:

1) try to find a different interface to Google Earth. For some parts of the HRD product, the static features that KML prodvides are quite adequate. I don't think KML supports what we were doing from the Sattellite Tracker application. Maybe hosting a web page inside the app, then usnig Google Earth on the web page, then animating Google Earth from the web page using JavaScript? Maybe something else?

2) try to find a product that replaces Google Earth. Get licensing together, sort out the installation issues, and add the supporting code to the product.

3) remove this feature from Satellite Tracker.

Meanwhile, the SatTracker code fails to create the Google Earth interface and doesn't say anything to the user. I've prepared this shelve set to add an error message:


2018-03-14 09:14

manager   ~0004488

I've made this checkin which removes some disconnected code related to this issue.


2018-03-14 09:15

manager   ~0004489

I've re-opened this issue. The issue is fixable; we just have to decide which approach we'd like to take. I'm assigning this issue to WA9PIE so he can drive that decision.

Issue History

Date Modified Username Field Change
2017-02-17 12:54 KB3NPH New Issue
2017-03-08 00:06 WA9PIE Project 3 - Current Dev List => 2 - Next Dev List (Holding Area)
2017-06-23 10:04 K7ZCZ Note Added: 0003270
2017-06-23 10:04 K7ZCZ Assigned To => WA9PIE
2017-06-23 10:04 K7ZCZ Status new => assigned
2017-06-23 10:21 WA9PIE Note Added: 0003271
2017-06-23 11:46 K7ZCZ Note Added: 0003272
2017-07-23 01:20 K7ZCZ Relationship added has duplicate 0001910
2018-02-26 11:00 WA9PIE Project 2 - Next Dev List (Holding Area) => 3 - Current Dev List
2018-02-26 11:09 WA9PIE Status assigned => resolved
2018-02-26 11:09 WA9PIE Resolution open => fixed
2018-02-26 11:09 WA9PIE Fixed in Version =>
2018-02-26 11:09 WA9PIE Testing => Not Started
2018-02-27 09:56 WA9PIE Assigned To WA9PIE => K7ZCZ
2018-03-01 04:16 g3ypp Note Added: 0004333
2018-03-01 23:27 WA9PIE Status resolved => assigned
2018-03-01 23:27 WA9PIE Resolution fixed => reopened
2018-03-01 23:27 WA9PIE Fixed in Version =>
2018-03-01 23:27 WA9PIE Testing Not Started => Beta Failed
2018-03-11 12:05 K7ZCZ Relationship added related to 0002132
2018-03-11 12:14 K7ZCZ Note Added: 0004471
2018-03-11 12:34 WA9PIE Status assigned => resolved
2018-03-11 12:42 K7ZCZ Note Added: 0004472
2018-03-13 14:20 WA9PIE Resolution reopened => not fixable
2018-03-14 09:14 K7ZCZ Note Added: 0004488
2018-03-14 09:15 K7ZCZ Assigned To K7ZCZ => WA9PIE
2018-03-14 09:15 K7ZCZ Status resolved => assigned
2018-03-14 09:15 K7ZCZ Note Added: 0004489