View Issue Details

IDProjectCategoryView StatusLast Update
0002038Ham Radio DeluxeBugpublic2017-08-05 18:58
ReporterK7ZCZ 
Assigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformIntel i7-5960XOSWindows 10 Professional x64OS Version1703
Product Version6.4.0.647 
Target VersionFixed in Version6.4.0.671 
Summary0002038: Setup installs obsolete *.PAL files
DescriptionSeems like there are *.PAL files installed which were at one time used for describing palettes of colours used by the waterfall feature in DM780.

As far as I can tell, the content of these files have been moved into static arrays in the PalData.H header, then accessed by a wrapper class in the PalData.cpp file.

I can't find any direct reference to any *.PAL file.

If these files are indeed obsolete, can we remove them from the installed image?

Steps To Reproduce1) Install HRD
2) go to the install folder
3) Look for *.pal files. For me, that looks like this:


C:\Users\mikeb>cd C:\Program Files (x86)\HRD Software LLC\Ham Radio Deluxe

C:\Program Files (x86)\HRD Software LLC\Ham Radio Deluxe>dir *.pal
 Volume in drive C has no label.
 Volume Serial Number is E454-4F55

 Directory of C:\Program Files (x86)\HRD Software LLC\Ham Radio Deluxe

08/08/2007 03:29 AM 3,090 BANANA.PAL
08/08/2007 03:29 AM 3,143 BIZARRE.PAL
08/08/2007 03:29 AM 2,918 BLUE.PAL
08/08/2007 03:29 AM 3,007 BLUEBAND.PAL
08/08/2007 03:29 AM 3,005 BROWN.PAL
08/08/2007 03:29 AM 3,328 Coldfire.pal
08/08/2007 03:29 AM 2,899 CYAN05.PAL
08/08/2007 03:29 AM 3,100 CYAN10.PAL
08/08/2007 03:29 AM 3,240 CYAN20.PAL
08/08/2007 03:29 AM 2,986 GRAY.PAL
08/08/2007 03:29 AM 2,969 JUNGLE.PAL
08/08/2007 03:29 AM 2,986 NEGATIVE.PAL
08/08/2007 03:29 AM 2,858 ORANGE.PAL
08/08/2007 03:29 AM 3,083 PINK.PAL
08/08/2007 03:29 AM 2,804 RAINBOW.PAL
08/08/2007 03:29 AM 2,709 SCOPE.PAL
08/08/2007 03:29 AM 2,607 SCOPE1.PAL
08/08/2007 03:29 AM 2,718 SUNBURST.PAL
08/08/2007 03:29 AM 3,398 Topo.pal
08/08/2007 03:29 AM 3,328 TTC.pal
08/08/2007 03:29 AM 2,874 YL2KF.PAL
              21 File(s) 63,050 bytes
               0 Dir(s) 48,837,988,352 bytes free

C:\Program Files (x86)\HRD Software LLC\Ham Radio Deluxe>
TagsNo tags attached.
ModuleAll
Sub-ModuleInstall
Testing Beta Successful

Relationships

Activities

ERIK

2017-06-18 19:28

developer   ~0003219

Need to confirm.

g3ucq

2017-06-24 04:04

viewer   ~0003281

*.PAL files still exist.

WA9PIE

2017-06-25 21:56

administrator   ~0003311

Do these still exist just because the installations we're doing are on-top-of a prior installation that had them?

I'm going to (a) shut down HRD... (b) remove the PAL files,.. (c) reinstall HRD... and (d) look for the PAL files.

WA9PIE

2017-06-25 22:01

administrator   ~0003312

Not fixed. The PAL files definitely come back.

K7ZCZ

2017-06-29 02:20

manager   ~0003415

Erik, this is an issue with the setup inventory. can you have a look, please?

g3ucq

2017-06-30 14:30

viewer   ~0003435

This not yet been fixed. I deleted the PAL files before installing v656 but the installation replaced them. No big deal though.

ERIK

2017-06-30 18:18

developer   ~0003439

Removed *.PAL, wondering about *.PDX_PAL.

g3ucq

2017-07-01 01:00

viewer   ~0003443

Fixed.

PD9FER

2017-07-27 02:28

viewer   ~0003748

Pal files still getting installed as per .664

Knipsel.JPG (34,050 bytes)
Knipsel.JPG (34,050 bytes)

g3ucq

2017-07-27 02:51

viewer   ~0003750

PAL files back again.

K7ZCZ

2017-07-27 11:31

manager   ~0003751

I can fix the *.PAL files.

We still need to know if *.PDX_PAL files should be installed or not.

K7ZCZ

2017-07-27 11:35

manager   ~0003752

I don't see the *.PAL files after a clean install of 664.

In fact, I can verify that they're not in the SetupHRD64_664.EXE installation package.

How is it that you're getting them installed, then? Can you please provide exact repro steps?

PD9FER

2017-07-27 12:17

viewer   ~0003757

It are in fact PDX_PAL files...
See my screenshot above.

They belong to the old PSK-31 Deluxe. and are obsolete

K7ZCZ

2017-07-30 09:49

manager   ~0003786

fixed with this change set:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/3708

g3ucq

2017-07-30 14:11

viewer   ~0003789

My PDX_PAL files were removed by v668

WA9PIE

2017-08-02 17:11

administrator   ~0003851

I looked for PAL files after this last install... on several machines... and I can't find one.

Done.

PD9FER

2017-08-02 17:32

viewer   ~0003852

Fixed

WA9PIE

2017-08-05 18:13

administrator   ~0003919

All completed during the 670 build/release.

Issue History

Date Modified Username Field Change
2017-06-18 12:49 K7ZCZ New Issue
2017-06-18 19:28 ERIK Note Added: 0003219
2017-06-18 19:28 ERIK Assigned To => WA9PIE
2017-06-18 19:28 ERIK Status new => assigned
2017-06-19 09:52 WA9PIE Fixed in Version => 6.4.0.652
2017-06-19 09:52 WA9PIE Description Updated View Revisions
2017-06-19 09:52 WA9PIE Steps to Reproduce Updated View Revisions
2017-06-24 04:04 g3ucq Note Added: 0003281
2017-06-25 21:56 WA9PIE Note Added: 0003311
2017-06-25 22:01 WA9PIE Note Added: 0003312
2017-06-25 22:53 WA9PIE Assigned To WA9PIE => K7ZCZ
2017-06-25 22:53 WA9PIE Module All (Installer) => (select)
2017-06-25 22:53 WA9PIE Testing => Beta Failed
2017-06-29 02:19 K7ZCZ Assigned To K7ZCZ => ERIK
2017-06-29 02:20 K7ZCZ Note Added: 0003415
2017-06-30 14:30 g3ucq Note Added: 0003435
2017-06-30 18:18 ERIK Note Added: 0003439
2017-07-01 01:00 g3ucq Note Added: 0003443
2017-07-01 08:23 WA9PIE Target Version => 6.4.0.652
2017-07-01 08:23 WA9PIE Fixed in Version 6.4.0.652 => 6.4.0.657
2017-07-04 23:17 WA9PIE Fixed in Version 6.4.0.657 => 6.4.0.658
2017-07-05 19:37 WA9PIE Fixed in Version 6.4.0.658 => 6.4.0.659
2017-07-05 19:38 WA9PIE Fixed in Version 6.4.0.659 =>
2017-07-27 02:28 PD9FER File Added: Knipsel.JPG
2017-07-27 02:28 PD9FER Note Added: 0003748
2017-07-27 02:51 g3ucq Note Added: 0003750
2017-07-27 11:31 K7ZCZ Note Added: 0003751
2017-07-27 11:35 K7ZCZ Note Added: 0003752
2017-07-27 12:17 PD9FER Note Added: 0003757
2017-07-30 09:48 K7ZCZ Assigned To ERIK => K7ZCZ
2017-07-30 09:49 K7ZCZ Status assigned => resolved
2017-07-30 09:49 K7ZCZ Resolution open => fixed
2017-07-30 09:49 K7ZCZ Testing => Not Started
2017-07-30 09:49 K7ZCZ Note Added: 0003786
2017-07-30 10:12 K7ZCZ Fixed in Version => 6.4.0.667
2017-07-30 11:23 K7ZCZ Fixed in Version 6.4.0.667 => 6.4.0.668
2017-07-30 14:11 g3ucq Note Added: 0003789
2017-08-02 17:11 WA9PIE Module (select) => All
2017-08-02 17:11 WA9PIE Testing Not Started => Beta Successful
2017-08-02 17:11 WA9PIE Note Added: 0003851
2017-08-02 17:32 PD9FER Note Added: 0003852
2017-08-05 18:09 WA9PIE Fixed in Version 6.4.0.668 => 6.4.0.670
2017-08-05 18:10 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2017-08-05 18:13 WA9PIE Note Added: 0003919
2017-08-05 18:13 WA9PIE Status resolved => closed
2017-08-05 18:27 WA9PIE Fixed in Version 6.4.0.670 => 6.4.0.671
2017-08-05 18:58 WA9PIE Target Version 6.4.0.652 =>