View Issue Details

IDProjectCategoryView StatusLast Update
0002064Ham Radio DeluxeBugpublic2017-09-18 00:08
ReporterK7ZCZ 
Assigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
PlatformIntel i7-5960XOSWindows 10 Professional x64OS Version1703
Product Version6.4.0.652 
Target VersionFixed in Version6.4.0.787 
Summary0002064: Logbook reloads even after aborted ADIF import
Description
It takes the logbook a while to load a large database. Reloading the database takes a long time, too.

The ADIF dialog will force a reload even if the ADIF dialog doesn't do any work.

Steps To Reproduce
1) Open up a large database in the Logbook
2) Access the ADIF import dialog (in the options dropdown, import, then ADIF)
3) Press "Cancel" in the resulting ADIF dialog; don't do an import.

BUG#1) The wait cursor comes up. It takes a while because the logbook is destroying the in-memory copy of the large logbook you've loaded; then loading a new copy of it.

TagsNo tags attached.
ModuleLogbook
Sub-ModuleImport Export
TestingNot Started

Relationships

Activities

K7ZCZ

2017-09-06 20:02

manager   ~0004125

fixed with this change set:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/3833

g3ucq

2017-09-08 03:18

viewer   ~0004139

Fixed

WA9PIE

2017-09-18 00:08

administrator   ~0004224

Closed as part of the 6.4.0.787 release.

Issue History

Date Modified Username Field Change
2017-06-21 18:46 K7ZCZ New Issue
2017-09-06 20:02 K7ZCZ Assigned To => K7ZCZ
2017-09-06 20:02 K7ZCZ Status new => resolved
2017-09-06 20:02 K7ZCZ Resolution open => fixed
2017-09-06 20:02 K7ZCZ Testing => Not Started
2017-09-06 20:02 K7ZCZ Note Added: 0004125
2017-09-07 18:18 K7ZCZ Fixed in Version => 6.4.0.784
2017-09-08 03:18 g3ucq Note Added: 0004139
2017-09-11 21:32 K7ZCZ Fixed in Version 6.4.0.784 => 6.4.0.785
2017-09-14 19:23 K7ZCZ Fixed in Version 6.4.0.785 => 6.4.0.787
2017-09-18 00:06 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2017-09-18 00:08 WA9PIE Note Added: 0004224
2017-09-18 00:08 WA9PIE Status resolved => closed