View Issue Details

IDProjectCategoryView StatusLast Update
0002071Ham Radio DeluxeMaintenancepublic2017-07-09 19:00
ReporterK7ZCZ 
Assigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version6.4.0.652 
Target VersionFixed in Version6.4.0.659 
Summary0002071: Cleanup: HRD project builds unused CMyBar class
DescriptionThe code doesn't use the CMyBar class, but it is built into the project.

The code is duplicated in the Mapper project, too; but the Mapper project does use that UI.

TagsNo tags attached.
ModuleRig Control
Sub-ModuleVarious
Testing N/A

Relationships

Activities

K7ZCZ

2017-06-22 23:34

manager   ~0003266

Sorry; it's both in the Mapper project and the main HRD rig control app. I don't think that was clear in my description.

Used in the Mapper project, so I left it.
Not used in the HRD rig control app, so I've removed it.

https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/3525

WA9PIE

2017-06-28 09:25

administrator   ~0003349

I'm marking these resolved. They're part of the dev cycle and not something that beta testers can test. If the developer has satisfied the profiler and warnings on them... or accomplished what he set out to do, they're done.

WA9PIE

2017-06-28 10:18

administrator   ~0003369

Bouncing these back to Assigned... I jumped the gun.

K7ZCZ

2017-06-28 23:55

manager   ~0003406

This was fixed per previous notes.

There's no real testing to do, since this is a cleanup issue.

WA9PIE

2017-07-04 23:30

administrator   ~0003463

Published in the 658 release.

WA9PIE

2017-07-05 00:00

administrator   ~0003498

Waiting to close them until a final item is tested.

WA9PIE

2017-07-05 19:39

administrator   ~0003570

These were all part of the 659 release.

Issue History

Date Modified Username Field Change
2017-06-22 19:07 K7ZCZ New Issue
2017-06-22 23:34 K7ZCZ Note Added: 0003266
2017-06-22 23:34 K7ZCZ Description Updated View Revisions
2017-06-28 09:25 WA9PIE Note Added: 0003349
2017-06-28 09:25 WA9PIE Status new => resolved
2017-06-28 09:25 WA9PIE Fixed in Version => 6.4.0.654
2017-06-28 09:25 WA9PIE Resolution open => fixed
2017-06-28 09:25 WA9PIE Assigned To => WA9PIE
2017-06-28 09:26 WA9PIE Testing => N/A
2017-06-28 10:18 WA9PIE Status resolved => assigned
2017-06-28 10:18 WA9PIE Note Added: 0003369
2017-06-28 10:20 WA9PIE Resolution fixed => open
2017-06-28 10:26 WA9PIE Fixed in Version 6.4.0.654 =>
2017-06-28 14:17 WA9PIE Assigned To WA9PIE => K7ZCZ
2017-06-28 23:55 K7ZCZ Status assigned => resolved
2017-06-28 23:55 K7ZCZ Resolution open => fixed
2017-06-28 23:55 K7ZCZ Note Added: 0003406
2017-07-01 08:30 WA9PIE Fixed in Version => 6.4.0.657
2017-07-04 23:17 WA9PIE Fixed in Version 6.4.0.657 => 6.4.0.658
2017-07-04 23:30 WA9PIE Note Added: 0003463
2017-07-04 23:30 WA9PIE Status resolved => closed
2017-07-04 23:30 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2017-07-04 23:58 WA9PIE Project Ham Radio Deluxe => 3 - Current Dev List
2017-07-05 00:00 WA9PIE Status closed => resolved
2017-07-05 00:00 WA9PIE Note Added: 0003498
2017-07-05 19:37 WA9PIE Fixed in Version 6.4.0.658 => 6.4.0.659
2017-07-05 19:39 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2017-07-05 19:39 WA9PIE Note Added: 0003570
2017-07-05 19:39 WA9PIE Status resolved => closed
2017-07-09 19:00 WA9PIE Testing => N/A