View Issue Details

IDProjectCategoryView StatusLast Update
0002084Ham Radio DeluxeBugpublic2017-07-19 12:14
ReporterK7ZCZ 
Assigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformIntel i7-5960XOSWindows 10 Professional x64OS Version1703
Product Version6.4.0.652 
Target VersionFixed in Version6.4.0.664 
Summary0002084: Connect window has blank help tab
DescriptionThe "Help" tab on the connect window is blank. If we can't help users, let's remove it. But preferably we can provide some text to give users advice about how this part of the software works.
Steps To Reproduce1) Start the Rig Control app
2) In the "Connect" dialog, click the "Help" tab

BUG#1) There's a big rich edit control there with nothing in it
TagsNo tags attached.
ModuleRig Control
Sub-ModuleAppearance/UI
TestingNot Started

Relationships

has duplicate 0002085 closedK7ZCZ 2 - Next Dev List (Holding Area) Connect window has blank help tab 

Activities

K7ZCZ

2017-06-28 14:47

viewer  

NoHelp.png (13,425 bytes)
NoHelp.png (13,425 bytes)

K7ZCZ

2017-07-13 12:46

viewer   ~0003647

With checkin https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/3623

Turns out a ton of code was copied and pasted across several of the project; a bug about loading RTF text from a resource was fixed elsewhere, but not in Rig Control.

g3ucq

2017-07-16 16:49

viewer   ~0003676

Can you add the default CI-V address for the IC-7300 94h?
Otherwise Fixed.

WA9PIE

2017-07-19 12:14

administrator   ~0003694

All shipped as part of the 664 release.

Issue History

Date Modified Username Field Change
2017-06-28 13:58 K7ZCZ New Issue
2017-06-28 14:47 K7ZCZ File Added: NoHelp.png
2017-07-05 00:20 K7ZCZ Relationship added has duplicate 0002085
2017-07-05 00:20 K7ZCZ Description Updated View Revisions
2017-07-05 00:20 K7ZCZ Steps to Reproduce Updated View Revisions
2017-07-05 00:20 K7ZCZ Sub-Module Interfacing => Appearance/UI
2017-07-13 12:46 K7ZCZ Assigned To => K7ZCZ
2017-07-13 12:46 K7ZCZ Status new => resolved
2017-07-13 12:46 K7ZCZ Resolution open => fixed
2017-07-13 12:46 K7ZCZ Testing => Not Started
2017-07-13 12:46 K7ZCZ Note Added: 0003647
2017-07-16 14:48 WA9PIE Fixed in Version => 6.4.0.664
2017-07-16 16:49 g3ucq Note Added: 0003676
2017-07-19 12:12 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2017-07-19 12:14 WA9PIE Note Added: 0003694
2017-07-19 12:14 WA9PIE Status resolved => closed