View Issue Details

IDProjectCategoryView StatusLast Update
0002106Ham Radio DeluxeBugpublic2017-07-19 12:14
ReporterK7ZCZ 
Assigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformVMware VMOSWindows 10 Professional x64OS Version10.0.15063
Product Version6.4.0.659 
Target VersionFixed in Version6.4.0.664 
Summary0002106: Rig Control: demo radio doesn't display frequencies correctly after VFO A/B swap
Description
Using the FT-950 radio, after swapping A/B VFO frequencies, the frequencies don't display correctly.

Steps To Reproduce1) Start up Rig Control. Use the DemoMatic FT-950 radio
2) VFOA probably has 14.235 tuned, and VFOB has 3.780
3) Press the A<>B button to swap frequencies

BUG#1) Now, 14.235 is displayed for both VFOs

4) Wait a few. It doesn't update, of course.
5) Press the A<>B button again

BUG#2) Now, 14.235 is in the A VFO and 3.78 is correctly in the B VFO.
TagsNo tags attached.
ModuleRig Control
Sub-ModuleRig Control
TestingNot Started

Relationships

Activities

K7ZCZ

2017-07-06 23:56

viewer   ~0003583

Turns out this problem seems to extend to all the Yaesu demo-mode radios. On my physical FT-450D radio, A/B swap works with the radio but not on the Rig Control UI.

1) Connect to real Yaesu FT-450D hardware
2) Let's assume A = 14.235 MHz, and B = 3.780
3) The radio is on A, showing 14.235 MHz. The Rig Control app shows 14.235 on the big display, and 3.780 on the smaller display.
4) Press A/B in rig control.
5) The radio flips to 3.780 and shows VFO-B. The Rig control app shows 3.780 in both the big display and small display.
6) Press A/B in rig control
7) The Rig control is Big = 14.235, Small = 3.780

The same problem occurs when using the A/B button on the radio itself.

K7ZCZ

2017-07-14 09:47

viewer   ~0003648

I have made this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/3625

which fixes A/B swapping on Yaesu and Kenwood demo radios.

I have also fixed this issue for the physical FT-450 radio. I think this problem exists for other radios, but I'm not able to test them and didn't change their behavior.

WA9PIE

2017-07-19 12:14

administrator   ~0003691

All shipped as part of the 664 release.

Issue History

Date Modified Username Field Change
2017-07-06 22:49 K7ZCZ New Issue
2017-07-06 23:56 K7ZCZ Note Added: 0003583
2017-07-14 09:47 K7ZCZ Note Added: 0003648
2017-07-14 09:47 K7ZCZ Assigned To => K7ZCZ
2017-07-14 09:47 K7ZCZ Status new => assigned
2017-07-14 09:47 K7ZCZ Status assigned => resolved
2017-07-14 09:47 K7ZCZ Resolution open => fixed
2017-07-14 09:47 K7ZCZ Testing => Not Started
2017-07-16 14:48 WA9PIE Fixed in Version => 6.4.0.664
2017-07-19 12:12 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2017-07-19 12:14 WA9PIE Note Added: 0003691
2017-07-19 12:14 WA9PIE Status resolved => closed