View Issue Details

IDProjectCategoryView StatusLast Update
0002107Ham Radio DeluxeBugpublic2017-08-05 19:00
ReporterKB3NPH 
Assigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.4.0.661 
Summary0002107: Rotor indicating 180 degrees off
DescriptionIn build .659, when testing the rotor control with the DEMO rotator, the indicator is showing 180 degrees off. When you click on a point in the Atlantic ocean, the rotor turns to the Pacific ocean. Not quite what it should be doing.

Steps To ReproduceConnect a Demo Rotator
click on Atlantic ocean area
Watch indicator dial and position of rotor moves to 270 degrees instead of 90 degrees.
TagsNo tags attached.
ModuleRotator
Sub-Module(select)
TestingNot Started

Relationships

has duplicate 0002104 closedK7ZCZ Clicking on map with mouse directe the rotor reverse 

Activities

K7ZCZ

2017-07-06 23:42

viewer   ~0003582

Sorry; another problem caused by refactor of the Locator code. The Heading() function had two versions: one that flipped 180 degrees, and one that didn't -- I chose the wrong one.

Fortunately, the Rotator app seems to be the only customer of the Heading() function, and only calls that function in one place.

Fix is checked in here:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/3592

KB3NPH

2017-07-11 02:04

administrator   ~0003619

Initial problem is confirmed as fixed.

An additional issue still remains un-resolved and that is if the rotor is configured as a "South Stop" the guage is flopped and indicates that WEST is at the 90 degree position on the gauge. When you click in the Atlantic ocean, which should indicate 90 degrees on the gauge, although the indicator is pointing EAST, toward 90 degrees, the gauge is actually indicating EAST is at the 280 degree mark and WEST is at 90 degrees. This is just opposite of what it should be. The gauge should not be flopped when the "South" stop is configured.

South Stop Rotator.jpg (185,061 bytes)
South Stop Rotator.jpg (185,061 bytes)
Proper display with North Stop.jpg (284,829 bytes)

g3ucq

2017-07-14 15:08

viewer   ~0003652

Fixed

WA9PIE

2017-07-14 16:54

administrator   ~0003653

These were all released in the 661 build.

Issue History

Date Modified Username Field Change
2017-07-06 22:54 KB3NPH New Issue
2017-07-06 23:42 K7ZCZ Note Added: 0003582
2017-07-06 23:42 K7ZCZ Project 1 - Backlog => 3 - Current Dev List
2017-07-06 23:43 K7ZCZ Assigned To => K7ZCZ
2017-07-06 23:43 K7ZCZ Status new => resolved
2017-07-06 23:43 K7ZCZ Resolution open => fixed
2017-07-06 23:43 K7ZCZ Sub-Module => (select)
2017-07-06 23:43 K7ZCZ Testing => Not Started
2017-07-07 13:38 K7ZCZ Relationship added has duplicate 0002104
2017-07-11 02:04 KB3NPH File Added: South Stop Rotator.jpg
2017-07-11 02:04 KB3NPH File Added: Proper display with North Stop.jpg
2017-07-11 02:04 KB3NPH Note Added: 0003619
2017-07-11 08:15 WA9PIE Fixed in Version => 6.4.0.660
2017-07-11 08:15 WA9PIE Testing => Not Started
2017-07-13 23:22 K7ZCZ Fixed in Version 6.4.0.660 => 6.4.0.661
2017-07-14 15:08 g3ucq Note Added: 0003652
2017-07-14 16:53 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2017-07-14 16:54 WA9PIE Target Version => 6.4.0.661
2017-07-14 16:54 WA9PIE Note Added: 0003653
2017-07-14 16:54 WA9PIE Status resolved => closed
2017-08-05 19:00 WA9PIE Target Version 6.4.0.661 =>