View Issue Details

IDProjectCategoryView StatusLast Update
0002117Ham Radio DeluxeBugpublic2017-07-19 12:14
ReporterWA9PIE 
Assigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version6.4.0.659 
Target VersionFixed in Version6.4.0.664 
Summary0002117: Sticky columns unstick after performing certain functions
DescriptionIn an email, Ron Whitsel, W3RJW, reports that sticky columns are "unstuck" after downloading from LOTW, using the filter function, and deleting a contract from the logbook. The program then asks the user to save these new settings.
Steps To ReproduceSee attached for exact steps to reproduce 2 of these 3 scenarios.
TagsNo tags attached.
ModuleLogbook
Sub-ModuleAppearance/UI
Testing Beta Successful

Relationships

Activities

WA9PIE

2017-07-09 11:01

administrator  

StickyColumnBugSteps.zip (4,540,909 bytes)

K7ZCZ

2017-07-10 23:50

viewer   ~0003615

Fixed. Some commands result in a secret call to the automatic width setting, which the width persistence code doesn't/cant notice, and then the widths change.

I've removed the call. It seems rude for the app to reset the widths without the user doing so.

https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/3617



WA9PIE

2017-07-11 07:55

administrator   ~0003620

I went through the test steps here and found no change. Column widths are still coming unstuck.

K7ZCZ

2017-07-11 09:53

viewer   ~0003625

Which build of the product were you using to test?

I don't think my fixes have been incorporated in any build. I'm unable to make installable builds of the product myself, so I don't think any build has yet been performed with the code I've checked in for this issue.

K7ZCZ

2017-07-12 23:51

viewer   ~0003645

resetting "Testing" field, as this code was never released in a publicly-visible build

WA9PIE

2017-07-16 14:56

administrator   ~0003672

This one looks good to me. I tested the reported scenarios successfully.

w4ase

2017-07-18 08:29

viewer   ~0003682

this now works for me

WA9PIE

2017-07-19 12:14

administrator   ~0003690

All shipped as part of the 664 release.

Issue History

Date Modified Username Field Change
2017-07-09 11:01 WA9PIE New Issue
2017-07-09 11:01 WA9PIE Status new => assigned
2017-07-09 11:01 WA9PIE Assigned To => K7ZCZ
2017-07-09 11:01 WA9PIE File Added: StickyColumnBugSteps.zip
2017-07-09 18:42 WA9PIE Module (select) => Logbook
2017-07-09 18:42 WA9PIE Testing => Not Started
2017-07-09 18:42 WA9PIE Sub-Module => Appearance/UI
2017-07-09 18:44 WA9PIE Project Ham Radio Deluxe => 3 - Current Dev List
2017-07-10 23:50 K7ZCZ Status assigned => resolved
2017-07-10 23:50 K7ZCZ Resolution open => fixed
2017-07-10 23:50 K7ZCZ Note Added: 0003615
2017-07-11 07:55 WA9PIE Note Added: 0003620
2017-07-11 07:55 WA9PIE Testing Not Started => Beta Failed
2017-07-11 09:53 K7ZCZ Note Added: 0003625
2017-07-12 23:51 K7ZCZ Testing Beta Failed => Not Started
2017-07-12 23:51 K7ZCZ Note Added: 0003645
2017-07-16 14:48 WA9PIE Fixed in Version => 6.4.0.664
2017-07-16 14:56 WA9PIE Note Added: 0003672
2017-07-16 14:56 WA9PIE Testing Not Started => Beta Successful
2017-07-18 08:29 w4ase Note Added: 0003682
2017-07-19 12:12 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2017-07-19 12:14 WA9PIE Note Added: 0003690
2017-07-19 12:14 WA9PIE Status resolved => closed