View Issue Details

IDProjectCategoryView StatusLast Update
0002123Ham Radio DeluxeBugpublic2017-07-19 12:14
ReporterPD9FER 
Assigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilitysometimes
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.4.0.664 
Summary0002123: Maidenhead locator squares are off not on correct possition
DescriptionIn Rotator the Locator boxes are not correctly displayed.
Differs per user.
Steps To ReproduceOpen HRD Rotator
Select Map > Maidenhead Squares,

Layout differs with the different avail maps.
TagsNo tags attached.
ModuleRotator
Sub-ModuleRotators
TestingNot Started

Relationships

Activities

K7ZCZ

2017-07-11 09:44

manager   ~0003624

Sorry, but I'll need something clearer.

As written, this isn't actionable -- there's no clear description of what the problem is. "Differs per user" doesn't tell me what changes for which users, or what might be different about the user.

Do you mean Windows user, or customer, or some setting that the user has?

What are the repro steps?

K7ZCZ

2017-07-11 09:55

manager   ~0003626

Also, it's imperative to know which build you were using when you noticed an issue.

PD9FER

2017-07-11 10:02

viewer   ~0003627

Appears in .660
Take note of your own QTH Locator and see if it is on the correct spot. (the home icon)
For instance I am in JO, but map puts me in JP
You also can see when loading another Map the positions are changing.

PD9FER

2017-07-11 10:27

viewer   ~0003629

Take for instance http://www.qsl.net/vu2sdu/grid.html
And compare with the displayed map in the program (see screenshot)

My Home Icon is correctly displayed on the map, But it is in the Overlaid box JP that one should be displaying JO

Compare with official map's

rotor.jpg (531,093 bytes)

PD9FER

2017-07-11 10:34

viewer   ~0003630

For my Location, note this "correct" labeled squares
http://www.solarham.net/dx/maps/eugrid.jpg

K7ZCZ

2017-07-12 00:41

manager   ~0003631

There was a discussion about this in chat almost an hour long.

Since there are no clear reproduction steps here, and no clear "observed" and "expected" desciptions, I've had to be very inductive in reasoning out what the problem might be.

My best conclusion is that the maidenhead labels in the images are wrong; that the bottom row of grid squares (nearest the south pole, nearest 90 degrees S, all end with "B", as in "AB" through "RB". This means that every other grid label in the column is off by one; the grid square labelled "JP" should really be "JO".

That aspect of the representation of maidenhead grid labels is unquestionably wrong in both the Logbook and the Rotator and I have fixed it with code that I've just checked in (in this change set: https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/3619)

However, I'm afraid I'm still unsure of the relationship to the problem I've observed to the problem reported by PD9FER.

K7ZCZ

2017-07-15 19:46

manager   ~0003666

I'm marking this as resolved.

g3ucq

2017-07-16 16:41

viewer   ~0003674

This seems to be a similar problem to that in Mapper which has been fixed.
The maidenhead square is correct for my QTH. Fixed.

WA9PIE

2017-07-19 12:14

administrator   ~0003688

All shipped as part of the 664 release.

Issue History

Date Modified Username Field Change
2017-07-11 09:24 PD9FER New Issue
2017-07-11 09:44 K7ZCZ Note Added: 0003624
2017-07-11 09:44 K7ZCZ Assigned To => K7ZCZ
2017-07-11 09:44 K7ZCZ Status new => feedback
2017-07-11 09:55 K7ZCZ Note Added: 0003626
2017-07-11 10:02 PD9FER Note Added: 0003627
2017-07-11 10:02 PD9FER Status feedback => assigned
2017-07-11 10:27 PD9FER File Added: rotor.jpg
2017-07-11 10:27 PD9FER Note Added: 0003629
2017-07-11 10:34 PD9FER Note Added: 0003630
2017-07-12 00:41 K7ZCZ Note Added: 0003631
2017-07-15 19:46 K7ZCZ Status assigned => resolved
2017-07-15 19:46 K7ZCZ Resolution open => fixed
2017-07-15 19:46 K7ZCZ Testing => Not Started
2017-07-15 19:46 K7ZCZ Note Added: 0003666
2017-07-16 01:54 K7ZCZ Project 1 - Backlog => 3 - Current Dev List
2017-07-16 14:48 WA9PIE Fixed in Version => 6.4.0.664
2017-07-16 16:41 g3ucq Note Added: 0003674
2017-07-19 12:12 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2017-07-19 12:14 WA9PIE Note Added: 0003688
2017-07-19 12:14 WA9PIE Status resolved => closed