View Issue Details

IDProjectCategoryView StatusLast Update
00021321 - BacklogBugpublic2018-03-16 06:04
Assigned ToK7ZCZ 
Status resolvedResolutionno change required 
Summary0002132: Lookup Google Earth
DescriptionWhen selecting a few QSOs from the logbook and then selecting Lookup/Google Earth some calls signs are put into the Atlantic Ocean off Africa. The rest are where they should be. I have been unable to determine why some call signs are put in the sea and not others.
Steps To ReproduceSelect QSOs from a log and then Lookup/Google Earth.
TagsNo tags attached.
TestingNot Started


related to 0001981 assignedWA9PIE 3 - Current Dev List Google Earth will not open from Satellite Tracker 



2017-07-14 14:53


Capture.JPG (60,582 bytes)
Capture.JPG (60,582 bytes)


2017-07-14 23:58

manager   ~0003658

Needs a lot more information to be actionable. I can't tell if this is from Logbook, or Mapper, or some other mechanism. Prepro setps would help, and I think the work involved in producting them would probably lead the reporter to their own diagnosis about the cause of the problem, which is likely bad data.


2017-07-15 03:33

reporter   ~0003661

Using Simon Brown's V5. The same Call signs are put into the sea off Africa. Others OK.


2017-07-15 04:15

reporter   ~0003662

I have found the reason why this is happening.
The QSOs shown as being 'in the sea' do not have Rotator bearings and Distance in the ALE window,
Pressing the Lookup button enters the information but it is not saved after clicking the Update button.
See the capture.jpg for one of the offenders.
I have also attached an .adif file. Of the QSOs these will NOT save the Lookup data for some reason.
The rest have the data and plot OK.

google earth test.ADI (10,881 bytes)
Capture-2.JPG (29,884 bytes)
Capture-2.JPG (29,884 bytes)


2017-07-31 22:43

developer   ~0003796

Also appears that if you use the Lookup>Google Earth function in logbook, the Longitude passed to the kml file has the wrong sign. When I plot a few US callsigns with valid locators, they are all mapped into Russia! The latitude appears to be correct, though I have not tested any southern hemisphere calls.


2017-07-31 23:00

developer   ~0003797

More information: If Logbook contains correct Lat/Lon values, they are passed correctly to Google Earth. If Logbook only contains a valid locator, the longitude is calculated with the incorrect sign (direction, E/W) which is then passed to the kml file.

Mike: I know that there are many places in the code where lat/lon are calculated from grid and some places vice-versa, and it seems each time a new feature was added in the (distant) past, the code was simply cut and pasted where needed. This would be a fine example of a place you could consolidate code into a library and call the functions when needed.


2017-07-31 23:03

developer   ~0003798

See N4KIT notes - good candidate for code consolidation into library


2018-03-11 14:27

manager   ~0004473

Copied and pasted code is a problem in this code base, but is irrelevant to this specific issue.

The "Rotator" settings aren't stored in the logbook. In order to save the location for your contact, you'll want to do these steps:

1) Open the editor for your contact. I do this by double-clicking their row in the Logbook's database display.
2) Activate the "Location" tab in the resulting "Modify" dialog. Note that the "Rotator" fields in the top part of the dialog are all empty. On the "Location" tab, the "Lat", "Lon", and "Locator" fields are also empty.

3) Press the "Lookup" button near the "Call" edit control. This causes the Rotator fields to populate, but it does _NOT_ cause the "Lat" and "Lon" fields in the Location tab to populate. If you pressed "Update (F7)" to save this entry, nothing would be saved because the Rotator fields are not persisted in the database. These controls identify themselves as "estimated latitutuded and longitutde" in tool tips.

4) Just to the right of the Rotator controls is a "Log Coordinates" button. Pressing this button will copy the estimated latitude and longitude to the Lat and Lon fields in the Location tab. That button press will also compute the distance field, and copy the Locator field. Pressing "Update (F7)" at this point will save the latitude and longitude for the contact into the database, as the Lat, Lon, Locator, and Distance fields in the "Location" tab _ARE_ persisted.

 Earth draws the stations at 0,0 coordinates after an export because no Lat,Lon data is available. The data isn't available because it isn't populated in the database. It can be looked up with a button press, but the data needs to be copied with another button press to the Location tab in order to be saved to the database.

Thus, the behaviour you're seeing is by design.


2018-03-16 06:04

reporter   ~0004492

Mike, K7ZCZ explanation works now but should the station centre on the screen? It does not for me.

Issue History

Date Modified Username Field Change
2017-07-14 14:53 g3ucq New Issue
2017-07-14 14:53 g3ucq File Added: Capture.JPG
2017-07-14 23:58 K7ZCZ Assigned To => K7ZCZ
2017-07-14 23:58 K7ZCZ Status new => feedback
2017-07-14 23:58 K7ZCZ Note Added: 0003658
2017-07-15 03:33 g3ucq Note Added: 0003661
2017-07-15 03:33 g3ucq Status feedback => assigned
2017-07-15 04:15 g3ucq File Added: Capture-2.JPG
2017-07-15 04:15 g3ucq File Added: google earth test.ADI
2017-07-15 04:15 g3ucq Note Added: 0003662
2017-07-31 22:43 n4kit Note Added: 0003796
2017-07-31 23:00 n4kit Note Added: 0003797
2017-07-31 23:03 n4kit Status assigned => confirmed
2017-07-31 23:03 n4kit Sub-Module (select) => General
2017-07-31 23:03 n4kit Module (select) => Logbook
2017-07-31 23:03 n4kit Note Added: 0003798
2018-03-11 12:05 K7ZCZ Relationship added related to 0001981
2018-03-11 14:27 K7ZCZ Status confirmed => resolved
2018-03-11 14:27 K7ZCZ Resolution open => no change required
2018-03-11 14:27 K7ZCZ Testing => Not Started
2018-03-11 14:27 K7ZCZ Note Added: 0004473
2018-03-16 06:04 g3ucq Note Added: 0004492