View Issue Details

IDProjectCategoryView StatusLast Update
0002134Ham Radio DeluxeBugpublic2017-07-19 12:14
ReporterK7ZCZ 
Assigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformIntel i7-5960XOSWindows 10 Professional x64OS Version1703
Product Version 
Target VersionFixed in Version6.4.0.664 
Summary0002134: Rig Control: sends blank command to Yaesu, Kenwood radios during init of read-only button
Description
Some buttons (like the "mode" menu button -- the one that lets the user switch the mode up or down incrementally) are write-only. That is, they don't know a particular value. "Next Mode" isn't the value of the next mode; the "Next Mode" command simply tells the radio to blindly go to the next mode.

The Rig Control app will, for such buttons, send a blank command to the radio. This isn't terribly harmful, but it isn't correct and isn't fast.
Steps To Reproduce
1) Observe radio communications in the debugger, or with a serial port sniffer
2) Start Rig Control
3) Connect a Yaesu radio (a physical one)
4) When the main window comes up, a blank ";" command will be sent because of the Mode Select button.

TagsNo tags attached.
ModuleRig Control
Sub-ModuleRig Control
TestingNot Started

Relationships

Activities

K7ZCZ

2017-07-15 15:50

viewer   ~0003664

a fix for this issue is checked into the Mike branch:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/3633

WA9PIE

2017-07-19 12:14

administrator   ~0003686

All shipped as part of the 664 release.

Issue History

Date Modified Username Field Change
2017-07-15 15:46 K7ZCZ New Issue
2017-07-15 15:50 K7ZCZ Assigned To => K7ZCZ
2017-07-15 15:50 K7ZCZ Status new => resolved
2017-07-15 15:50 K7ZCZ Resolution open => fixed
2017-07-15 15:50 K7ZCZ Note Added: 0003664
2017-07-16 14:48 WA9PIE Fixed in Version => 6.4.0.664
2017-07-19 12:12 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2017-07-19 12:14 WA9PIE Note Added: 0003686
2017-07-19 12:14 WA9PIE Status resolved => closed