View Issue Details

IDProjectCategoryView StatusLast Update
0002136Ham Radio DeluxeBugpublic2017-08-05 18:27
Reporterg3ucq 
Assigned ToK7ZCZ 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.4.0.671 
Summary0002136: Mapper. Pop out info has Chinese characters.
DescriptionChinese characters in info box.
Steps To ReproduceIn Mapper. Touching a station peg brings out the info box with some Chinese characters.
TagsNo tags attached.
ModuleMapper
Sub-ModuleMaps
Testing Not Tested

Relationships

Activities

K7ZCZ

2017-07-16 19:36

viewer   ~0003678

Repro steps are needed, please.

g3ucq

2017-07-17 03:17

viewer   ~0003679

Load Mapper. Select the QSO range from Stations/HRD Logbook Query.
Hovering the mouse pointer over a station peg brings out the QSO info box.
Some of the characters are Chinese (or some Asian language)
See the file 8P9AL.

8p9al.jpg (64,101 bytes)
8p9al.jpg (64,101 bytes)

K7ZCZ

2017-07-25 00:38

viewer   ~0003733

Here are accurate repro steps:

1) Start Mapper
2) Use the "Logbook Query" command in the "Station" menu
3) In the resulting "Ham Radio Deluxe Logbook query" dialog, use the "Select" button on the "Logbook" tab to open a database

HINT: databases are stored by default in the Roaming profile; for example C:\Users\mikeblas.PROZAC\AppData\Roaming\HRDLLC\HRD Logbook

4) Wait for the records to load
5) Activate the "Contacts" tab
6) Select some records. An easy way to do so is to mark the "Bands" check box
7) Then click the "?" push button next to the edit contol
8) In the resulting "Bands" popup, pick a few bands which will be in the database
9) Click the "apply" button
10) Wait for the records to filter. Pins should be drawn on the map corresponding to the found QSOs
11) close the "Ham Radio Deluxe Logbook Query" dialog
12) Hover near a pin

K7ZCZ

2017-07-25 00:41

viewer   ~0003734

fixed with this change set:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/3697

K7ZCZ

2017-07-25 09:12

viewer   ~0003736

Found a couple more character set problems, and a couple more longitude orientation issues. Fixed with this change set:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/3698

g3ucq

2017-07-29 03:44

viewer   ~0003770

I confirm the fix

PD9FER

2017-08-03 10:21

viewer   ~0003869

Confirm Fix

n4kit

2017-08-03 12:28

viewer   ~0003875

I can't get the Logbook Query to work - it never has for me, maybe I'm doing something wrong. When I connect to the logbook, it says there are 2500 (or so) entries loaded, but nothing plots.

Because it never worked, I never used it, so I'm not very familiar with this module. I'm with Mike C. on this one.

n4kit

2017-08-03 12:36

viewer   ~0003876

Last edited: 2017-08-03 12:36

View 2 revisions

OK, I got it to do something now - apparently the date controls are VERY touchy. Anyway, I don't see any whack characters so I guess as far as this item goes, close it.

g3ucq

2017-08-03 16:34

viewer   ~0003883

As long as the QSOs have a locator logged the QSO will plot. Fixed for me.

WA9PIE

2017-08-05 18:13

administrator   ~0003908

All completed during the 670 build/release.

Issue History

Date Modified Username Field Change
2017-07-16 17:22 g3ucq New Issue
2017-07-16 19:36 K7ZCZ Note Added: 0003678
2017-07-17 03:17 g3ucq File Added: 8p9al.jpg
2017-07-17 03:17 g3ucq Note Added: 0003679
2017-07-25 00:38 K7ZCZ Note Added: 0003733
2017-07-25 00:41 K7ZCZ Assigned To => K7ZCZ
2017-07-25 00:41 K7ZCZ Status new => resolved
2017-07-25 00:41 K7ZCZ Resolution open => fixed
2017-07-25 00:41 K7ZCZ Sub-Module (select) => Maps
2017-07-25 00:41 K7ZCZ Module (select) => Mapper
2017-07-25 00:41 K7ZCZ Testing => Not Started
2017-07-25 00:41 K7ZCZ Note Added: 0003734
2017-07-25 00:43 K7ZCZ Project 1 - Backlog => 3 - Current Dev List
2017-07-25 09:12 K7ZCZ Note Added: 0003736
2017-07-27 17:57 K7ZCZ Fixed in Version => 6.4.0.667
2017-07-29 03:44 g3ucq Note Added: 0003770
2017-08-03 10:21 PD9FER Note Added: 0003869
2017-08-03 12:28 n4kit Note Added: 0003875
2017-08-03 12:36 n4kit Note Added: 0003876
2017-08-03 12:36 n4kit Note Edited: 0003876 View Revisions
2017-08-03 16:34 g3ucq Note Added: 0003883
2017-08-05 18:07 WA9PIE Testing Not Started => Not Tested
2017-08-05 18:09 WA9PIE Fixed in Version 6.4.0.667 => 6.4.0.670
2017-08-05 18:10 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2017-08-05 18:13 WA9PIE Note Added: 0003908
2017-08-05 18:13 WA9PIE Status resolved => closed
2017-08-05 18:27 WA9PIE Fixed in Version 6.4.0.670 => 6.4.0.671