View Issue Details

IDProjectCategoryView StatusLast Update
0002150Ham Radio DeluxeBugpublic2017-08-05 18:27
ReporterKB3NPH 
Assigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.4.0.671 
Summary0002150: Grid Square (Maidenhead) maps in Rotator not accurate.
DescriptionTicket #877339

Bruce has reported that the Maidenhead overlay for the map in the Rotator software is not accurate. It appears in his display the L column is missing and the A column is missing.

As a comparison I have included screenshots from both Bruces computer and the one I have in my computer. The A column is indeed missing from my display, however mine does show the L column. There appears to be other discrpencies in Bruces map also. See his notes from the ticket.

This is exactly what Bruce reported in his ticket::

"Bruce posted 07/20/2017 11:47 AM
Thr new 664 version corrects the rotor control but as in many years past the L column is missing in the maidenhead squares and now so is the A column which is totally missing. This throws the calibration of the squares off about one column which makes it hard to use the squares to popint the antena in the correct direction...L column is not populated and teh A column is totaly missing

Bruce posted 07/20/2017 12:34 PM
Looking at it again..You have the A column mislabled as S...I dont think there is an S colume as squares stop at R...The L column is still missing its letters
Tnx
TagsNo tags attached.
ModuleRotator
Sub-ModuleMaps
Testing Not Tested

Relationships

Activities

KB3NPH

2017-07-21 12:56

administrator  

GS Overlay from Bruce.jpg (256,080 bytes)
GS Overlay from Bruce.jpg (256,080 bytes)
GS Overlay From My system.jpg (451,944 bytes)

K7ZCZ

2017-07-23 01:40

viewer   ~0003714

Thanks for the clear report, ya'll.

The problem with the S column showing instead of the A column is my fault for a tweak I had made to the Locator code.
The missing rightmost column (L column for the default view and 100% zoom) is a long-standing issue. Or, at least, before I got here: it reproduces in 647.

Note that this bug also affected the dusk-line window in Logbook.

I've fixed both issues with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/3674

PD9FER

2017-07-28 06:06

viewer   ~0003767

Build 667
A Collumns missing.
See screenshot

A Collumns.jpg (518,836 bytes)

g3ucq

2017-07-29 03:21

viewer   ~0003768

Build 667
A column showing for me.

rotator2.JPG (73,046 bytes)
rotator2.JPG (73,046 bytes)

WA9PIE

2017-08-02 14:19

administrator   ~0003834

From what I can see, the "N column" is missing.

Rotor - N column missing.PNG (1,181,635 bytes)

g3ucq

2017-08-02 14:29

viewer   ~0003838

I see column N but the R column on the right edge is partly missing and the rest of the column appears on the left.

Capture.JPG (91,997 bytes)
Capture.JPG (91,997 bytes)

K7ZCZ

2017-08-02 23:55

viewer   ~0003859

The map has to wrap somewhere. The app locates your QTC in the center of your screen, then scrolls the map around it. That might make a square wrap from the right edge to the left edge because of where your QTH falls within the large grid square.

In the G3UCQ case, if we didn't draw the text (even though it's partially clipped) users wouldn't see the text at all -- and assume there was no R column. In Ferry's case, that's exactly what happens on the left edge; since the left most grid square starts off the client area of the window, the text isn't drawn into it and Ferry assumed it was actually missing. Obviously, it's there -- just not labelled.

I can fix this so that the grid square name is always drawn, even if the square is partially off the window ...

K7ZCZ

2017-08-03 00:06

viewer   ~0003861

It would help to have the grid square locations you each use in your "My Station" settings.

g3ucq

2017-08-03 00:59

viewer   ~0003862

Mine is IO70he

PD9FER

2017-08-03 10:17

viewer   ~0003867

build 669 Not fixed
Locator here JO22OQ
Missing the A collum

n4kit

2017-08-03 11:50

viewer   ~0003873

In my case (home:FM16pt) the "O" column is the split at the left edge. If I manually type an "O" locator in, it is correctly pointed on the map, even though the labels in that column are missing, and I suspect the missing labels are due to the column split.

In my opinion, call it done, unless labeling the split column is easy..

g3ucq

2017-08-03 16:20

viewer   ~0003881

"In my opinion, call it done, unless labeling the split column is easy.. "
I will second that.

WA9PIE

2017-08-05 18:13

administrator   ~0003905

All completed during the 670 build/release.

Issue History

Date Modified Username Field Change
2017-07-21 12:56 KB3NPH New Issue
2017-07-21 12:56 KB3NPH File Added: GS Overlay from Bruce.jpg
2017-07-21 12:56 KB3NPH File Added: GS Overlay From My system.jpg
2017-07-23 01:40 K7ZCZ Assigned To => K7ZCZ
2017-07-23 01:40 K7ZCZ Status new => resolved
2017-07-23 01:40 K7ZCZ Resolution open => fixed
2017-07-23 01:40 K7ZCZ Note Added: 0003714
2017-07-24 18:45 K7ZCZ Project 1 - Backlog => 3 - Current Dev List
2017-07-27 17:56 K7ZCZ Fixed in Version => 6.4.0.667
2017-07-28 06:06 PD9FER File Added: A Collumns.jpg
2017-07-28 06:06 PD9FER Note Added: 0003767
2017-07-29 03:21 g3ucq File Added: rotator2.JPG
2017-07-29 03:21 g3ucq Note Added: 0003768
2017-08-02 14:19 WA9PIE File Added: Rotor - N column missing.PNG
2017-08-02 14:19 WA9PIE Note Added: 0003834
2017-08-02 14:29 g3ucq File Added: Capture.JPG
2017-08-02 14:29 g3ucq Note Added: 0003838
2017-08-02 23:55 K7ZCZ Note Added: 0003859
2017-08-03 00:06 K7ZCZ Note Added: 0003861
2017-08-03 00:59 g3ucq Note Added: 0003862
2017-08-03 10:17 PD9FER Note Added: 0003867
2017-08-03 11:50 n4kit Note Added: 0003873
2017-08-03 16:20 g3ucq Note Added: 0003881
2017-08-05 18:07 WA9PIE Testing Not Started => Not Tested
2017-08-05 18:09 WA9PIE Fixed in Version 6.4.0.667 => 6.4.0.670
2017-08-05 18:10 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2017-08-05 18:13 WA9PIE Note Added: 0003905
2017-08-05 18:13 WA9PIE Status resolved => closed
2017-08-05 18:27 WA9PIE Fixed in Version 6.4.0.670 => 6.4.0.671