View Issue Details

IDProjectCategoryView StatusLast Update
0002151Ham Radio DeluxeBugpublic2018-04-09 14:37
ReporterK7ZCZ 
Assigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformIntel i7-5960XOSWindows 10 Professional x64OS Version1703
Product Version6.4.0.664 
Target VersionFixed in Version6.4.0.806 
Summary0002151: Rig Control: Icom protocol handler doesn't correctly parse frequency change announcements.
DescriptionThere's code common to all of the Icom radios that parses data sent from the radio in the the CIV protocol. One part of the parsing code only looks at a couple of bytes of data rather than the whole structure, and incorrectly assumes certain strings of bytes from the radio are announcing a frequency change. They're not; they're announcing something else. The code in HRD Rig Control reads that data, misinterprets it, and uses it to show there resulting bogus value as a tuned frequency in rig control.

This probably affects all Icom radios that speak the modern CI-V protocol, but all I have to test at the moment is my ID-51A. The problem readily reproduces with that radio, but I don't want to attempt a fix until I have at least one other Icom to try out. The code in question is in the path of reading data from any Icom radio.
Steps To Reproduce
1) Connect your ID-51A
2) Set it to memory mode
3) Use the dial to flick rapidly among pre-programmed memory channels. For me, this means I'm always among 9-digit frequencies in 2m and 70cm bands; like "146.880.000" and "444.550.000".
4) While flipping through these channels, it's easy to see that the rig control app sometimes draws a seven-digit frequency, like "1.630.250". This is way out of range for the radio.
5) If you're lucky/careful, you can get Rig Control to display that frequency for a long while.
TagsNo tags attached.
ModuleRig Control
Sub-ModuleRig Control
Testing Beta Successful

Relationships

Activities

K7ZCZ

2018-04-01 17:16

manager   ~0004621

This was fixed with this checkin a couple weeks ago; looks like I forgot to mark this issue resolved.
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/3944

g3ypp

2018-04-03 12:06

viewer   ~0004635

I don't think I have ever seen this behaviour on my IC-7600, but if it was it is not there in .799 so seems fixed.

Issue History

Date Modified Username Field Change
2017-07-21 21:20 K7ZCZ New Issue
2017-09-18 00:14 WA9PIE Project 3 - Current Dev List => 2 - Next Dev List (Holding Area)
2018-03-04 11:49 K7ZCZ Assigned To => K7ZCZ
2018-03-04 11:49 K7ZCZ Status new => assigned
2018-04-01 17:16 K7ZCZ Status assigned => resolved
2018-04-01 17:16 K7ZCZ Resolution open => fixed
2018-04-01 17:16 K7ZCZ Note Added: 0004621
2018-04-02 10:42 K7ZCZ Project 2 - Next Dev List (Holding Area) => 3 - Current Dev List
2018-04-02 10:45 K7ZCZ Fixed in Version => 6.4.0.798
2018-04-03 12:06 g3ypp Note Added: 0004635
2018-04-04 14:47 WA9PIE Status resolved => closed
2018-04-04 14:47 WA9PIE Description Updated View Revisions
2018-04-04 14:47 WA9PIE Steps to Reproduce Updated View Revisions
2018-04-04 14:47 WA9PIE Testing Not Started => Beta Successful
2018-04-07 19:23 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2018-04-07 19:25 WA9PIE Fixed in Version 6.4.0.798 => 6.4.0.805
2018-04-09 14:37 WA9PIE Fixed in Version 6.4.0.805 => 6.4.0.806