View Issue Details

IDProjectCategoryView StatusLast Update
0002158Ham Radio DeluxeBugpublic2017-08-05 18:27
ReporterPD9FER 
Assigned ToK7ZCZ 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.4.0.671 
Summary0002158: Trying to Restore a large logfile > 126K contacts gives Improper argument to popup
DescriptionWhen having a empty database, trying to restore the XML (to be found on our Google Drive page... 199MB)
Errors popup saying: Encountered a Improper Argument.

You can Okay it and the logbook will be there after some time.

When done and you want to delete all entries the same message appears and nothing gets deleted.
Steps To ReproduceCreate an empty log
Files > Backups > Restore
Browse to the XML referred earlier on G-Drive
Accept and continue

2nd case:
Do Ctrl A to select all entries
Delete and Ok it.

 
Additional Informationhttps://support.ham-radio-deluxe.com/scp/tickets.php?id=10791

Replicated also by Mike WA9PIE
TagsNo tags attached.
ModuleLogbook
Sub-ModuleData
Testing Not Tested

Relationships

related to 0001707 closedK7ZCZ Large ADIF import causes Logbook to crash 

Activities

K7ZCZ

2017-07-26 19:27

viewer   ~0003747

Need a copy of the logfile, please.

K7ZCZ

2017-07-30 23:36

viewer   ~0003792

There are two issues here.

One is described in the linked issue 0001707 and also reported here. The customer-reported issue in the support ticket linked from this bug is at least slightly different; examining the ticket reveals that the user actually reported an "out of memory" error, not a "invalid argument" message. I believe the out of memory problem is fixed by the changed that also fix the 1707 issue, but I can't be completely sure because I was not able to reliably reproduce the out of memory error. After the changes I've made, it _never_ reproduces rather than just reproducing some times.

In the future, I think it would save some confusion and time if the reported issue was faithfully described in the Mantis issue, rather than mutated into a different description.

K7ZCZ

2017-07-30 23:36

viewer   ~0003793

fixed with related issue

PD9FER

2017-08-02 17:06

viewer   ~0003850

Backup of the mentioned log goes fast - Fixed

Deleting (CTRL-A Del) still takes forever to wipe all data (12 minutes) No errors though - Partial Fix

Restoring XML Backup Refreshes log every 5000 entries. slowing the restore (the more entries, the more time it takes in the process )
After 20 minutes At 109.000, system gets unresponsive. (could be the log is corrupt) No errors in between For the Error message it is a FIX

K7ZCZ

2017-08-02 21:22

viewer   ~0003857

Turns out the "Invalid Argument" errors are caused by a data structure that implements the "log file" view in the Logbook. Details of the fix are in the original 1707 issue. But as further explanation, the orphaned critical section makes the application unstable. Anything that tries to write to the "log file" view will end up blocking on the critical section if it's on a different thread that owns the ; or causing the same "Invalid Argument" message if it's on the same thread.

This fix doesn't address performance in any aspect of the logbook. We have lots of issues to manage, so it's important to attack them sensibly -- issues which are over-scoped are too difficult to work, manage, estimate, or close. If you'd like to have a mantis issue that traks performance while deleting records, please feel free to open one; I can address it when I re-work the Logbook data structures.

g3ucq

2017-08-03 15:54

viewer   ~0003877

I cannot test this as I don't have a large logbook. Could a large log be put in the Dropbox please?

g3ucq

2017-08-03 16:16

viewer   ~0003879

Update: I found Mike, WA9PIE's adif log on issue 1707 so I saved that and imported the file into an empty log.
No problems and the process took about 1 1/2 minutes.
I then created a backup and then deleted all the QSOs. No problem.
I then imported the backup with no problems again. That took about 1 1/2 minutes.
This with v669

WA9PIE

2017-08-05 18:13

administrator   ~0003901

All completed during the 670 build/release.

Issue History

Date Modified Username Field Change
2017-07-25 12:00 PD9FER New Issue
2017-07-26 19:27 K7ZCZ Assigned To => K7ZCZ
2017-07-26 19:27 K7ZCZ Status new => feedback
2017-07-26 19:27 K7ZCZ Sub-Module Various => Data
2017-07-26 19:27 K7ZCZ Note Added: 0003747
2017-07-26 19:31 K7ZCZ Relationship added related to 0001707
2017-07-30 23:32 K7ZCZ Project 1 - Backlog => 3 - Current Dev List
2017-07-30 23:36 K7ZCZ Note Added: 0003792
2017-07-30 23:36 K7ZCZ Status feedback => resolved
2017-07-30 23:36 K7ZCZ Resolution open => fixed
2017-07-30 23:36 K7ZCZ Testing => Not Started
2017-07-30 23:36 K7ZCZ Note Added: 0003793
2017-08-02 07:33 K7ZCZ Fixed in Version => 6.4.0.669
2017-08-02 17:06 PD9FER Note Added: 0003850
2017-08-02 21:22 K7ZCZ Note Added: 0003857
2017-08-03 15:54 g3ucq Note Added: 0003877
2017-08-03 16:16 g3ucq Note Added: 0003879
2017-08-05 18:07 WA9PIE Testing Not Started => Not Tested
2017-08-05 18:09 WA9PIE Fixed in Version 6.4.0.669 => 6.4.0.670
2017-08-05 18:10 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2017-08-05 18:13 WA9PIE Note Added: 0003901
2017-08-05 18:13 WA9PIE Status resolved => closed
2017-08-05 18:27 WA9PIE Fixed in Version 6.4.0.670 => 6.4.0.671