View Issue Details

IDProjectCategoryView StatusLast Update
00021673 - Current Dev ListBugpublic2017-09-25 12:54
ReporterK7ZCZ 
Assigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformVMware VMOSWindows 10 Professional x64OS Version10.0.15063
Product Version6.4.0.647 
Target VersionFixed in Version 
Summary0002167: Setup: installs obsolete *.msstyles files
DescriptionSetup installs a bunch of *.msstyles files. I can't tell what they do. They look like executable images, but I'm having some trouble figuring out what references them.

By their names, they seem to be related to setting a style (skin?) for something.

I see a reference to the files in the Rotator code, and in the CodeJock libraries. We need to investigate these files; if we're not using them, they shouldn't be installed. They're executable, and therefore a risk (even if a very small one) to ship; they take space in the distribution and on customer's machines.

Judging by the file dates, it seems like they're not being consistently built by the build process.

Steps To Reproduce1) Install the product
2) Look in the C:\Program Files (x86)\HRD Software LLC\Ham Radio Deluxe\Styles directory for *.msstyles files

Maybe they compress well, but they total more 90 megabytes.
Additional InformationC:\Program Files (x86)\HRD Software LLC\Ham Radio Deluxe>dir *.msstyles /s
 Volume in drive C has no label.
 Volume Serial Number is EA3C-72E8

 Directory of C:\Program Files (x86)\HRD Software LLC\Ham Radio Deluxe\Styles

07/19/2017 06:03 AM 8,835,216 CodeOpus.msstyles
07/19/2017 06:03 AM 9,162,896 CodeOpusC.msstyles
07/19/2017 06:03 AM 3,289,088 ConcaveC.msstyles
07/19/2017 06:03 AM 3,428,352 ConcaveD.msstyles
07/19/2017 06:03 AM 3,301,376 ConcaveL.msstyles
07/19/2017 06:03 AM 3,076,096 devART.msstyles
07/19/2017 06:03 AM 3,026,944 devARTa.msstyles
07/19/2017 06:03 AM 3,076,096 devARTg.msstyles
07/19/2017 06:03 AM 3,887,104 Foton.msstyles
07/19/2017 06:03 AM 4,788,368 Fresco.msstyles
07/19/2017 06:03 AM 7,614,608 iTunesA.msstyles
07/19/2017 06:03 AM 7,848,080 iTunesB.msstyles
07/19/2017 06:03 AM 3,624,960 LunaInsp.msstyles
07/19/2017 06:03 AM 4,067,328 Peppered3.msstyles
07/19/2017 06:03 AM 3,600,528 ProLCD WinFlag.msstyles
07/19/2017 06:03 AM 3,600,528 ProLCD.msstyles
07/19/2017 06:03 AM 6,979,728 Sustenance Compact.msstyles
07/19/2017 06:03 AM 6,979,728 Sustenance.msstyles
07/19/2017 06:03 AM 5,992,592 Thallos.msstyles
07/19/2017 06:03 AM 1,343,632 zune.msstyles
              20 File(s) 97,523,248 bytes

     Total Files Listed:
              20 File(s) 97,523,248 bytes
               0 Dir(s) 48,196,288,512 bytes free
TagsNo tags attached.
ModuleAll
Sub-ModuleInstall
TestingNot Started

Relationships

Activities

n4kit

2017-08-02 20:08

developer   ~0003855

As I recall, at one time at least Rotator, and maybe other modules, had the option to apply skins. They caused so much trouble for Rick, I'm pretty sure he removed the option to use them. I'm 90% sure you could remove them without effect. I will go back through old notes and emails and see if I can find anything on it.

n4kit

2017-08-02 20:12

developer   ~0003856

Reminder sent to: K7ZCZ

Mike - I added a note to this. I think these are files for skins as you suggest and that skinning was removed as an option a couple of years ago by Rick because they caused so many problems. I will dig back through old emails and see if I can find anything about it. If you need to reach me direct, my email is chrisn4kit@gmail.com.

n4kit

2017-08-07 13:24

developer   ~0003940

08/07/2017: I deleted all of the *.msstyles files from C:\Program Files (x86)\HRD Software LLC\Ham Radio Deluxe\Styles folder. So far there are no adverse effects in Logbook or Rotator. I will continue to hammer on the Appearance options to see if anything bad happens.

I compressed (zipped) one 8.6 MB file and it reduced to 733 kb, so they compress well, but still - even compressed they take up 8.8 MB.

n4kit

2017-09-15 11:37

developer   ~0004192

9/15/17: Build 785 - I once again deleted all the *.msstyles files from C:\Program Files (x86)\HRD Software LLC\Ham Radio Deluxe\Styles and found no adverse effects in any of the modules.

K7ZCZ

2017-09-15 12:28

viewer   ~0004193

Sorry, thought I had made a note here. In reviewing the code, I found one spot where a specific *.msstyles file is referenced; and another place where a dialog box is offered allowing the user to choose an *.msstyles file. I have to review these to see if they're connected to anything -- and if so, what?

n4kit

2017-09-15 12:40

developer   ~0004194

Any idea which module / what dialog box? I went searching in the UI through all the "options" dialogs where I could remember we used to be able to select skins and could find none.
My opinion is that skins support was removed a very long time ago because they caused too many problems. Users are used to not having that "feature" so I would say remove any residuals in the code and remove the styles files from the project.

The only potential user impact I can think of is if someone is still running a very old v6 build and upgrades, there may be a significant change in their UI appearance.

I'm pretty sure the first build of 6.1 is where they were removed - somewhere around build 144 - June 2013.

n4kit

2017-09-15 12:43

developer   ~0004195

Oh, and as I'm sure you've discovered, 'PC was notorious for removing stuff by commenting out the code and leaving all the stranded dependencies in place!

K7ZCZ

2017-09-17 10:50

viewer   ~0004197

There was code for a File Open dialog specialized to search for *.msstyles files (but not *.cjstyles files, for some reason). I removed this code in an earlier checkin because it was unused.

I tracked down the remaining references to *.msstyles and *.cjstyles and I'm convinced we're not using them. I've cleaned up more unused code and disconnected a few things which were connected to unused code, so we're in a bit better shape for that. But I think that work further demonstrates that the *.msstyles files aren't being loaded.

In removing them from the installer build, I discovered that we've got a ton of files (!) checked-in that shouldn't be tracked in source control. They included the *.msstyles and *.cjstyles files, so I've removed those from version control.

This work saves space in the setup image -- about 4 megabytes, which is a little less than 4% of the file size. It also saves about 100 megs of space on the user's disk during install. These aren't too important to me; what worries me is that we're shipping code that we don't build, didn't build correctly, and don't manage. These f iles might not have executable code in them, but I don't even know that because I don't seem to have any source or lineage for them.

K7ZCZ

2017-09-18 09:07

viewer   ~0004234

Lots of dead code and commented-out code removed. The *.msstyles and *.cjstyles files were checked-in in two different places, both removed. Notably, temporary files created by the InstallAware build were checked in, so I removed all of those. This work reduced the installer image size by about 5%. More importantly, we're not shipping 100 megs of executable files that we don't build ourselves. Further, removing the temporary files from source control eliminates the chance we'll trip over some ancient, partially-built file in the setup image.

Everything in this change set:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/3865

Issue History

Date Modified Username Field Change
2017-07-31 11:18 K7ZCZ New Issue
2017-08-01 09:49 K7ZCZ Steps to Reproduce Updated View Revisions
2017-08-01 09:49 K7ZCZ Additional Information Updated View Revisions
2017-08-01 09:49 K7ZCZ Module (select) => All
2017-08-01 09:49 K7ZCZ Sub-Module (select) => Install
2017-08-02 20:08 n4kit Note Added: 0003855
2017-08-02 20:12 n4kit Note Added: 0003856
2017-08-07 13:24 n4kit Note Added: 0003940
2017-09-14 23:01 K7ZCZ Assigned To => K7ZCZ
2017-09-14 23:01 K7ZCZ Status new => assigned
2017-09-15 11:37 n4kit Note Added: 0004192
2017-09-15 12:28 K7ZCZ Note Added: 0004193
2017-09-15 12:40 n4kit Note Added: 0004194
2017-09-15 12:43 n4kit Note Added: 0004195
2017-09-17 10:50 K7ZCZ Note Added: 0004197
2017-09-18 00:14 WA9PIE Project 3 - Current Dev List => 2 - Next Dev List (Holding Area)
2017-09-18 09:07 K7ZCZ Status assigned => resolved
2017-09-18 09:07 K7ZCZ Resolution open => fixed
2017-09-18 09:07 K7ZCZ Note Added: 0004234
2017-09-25 12:54 WA9PIE Project 2 - Next Dev List (Holding Area) => 3 - Current Dev List