View Issue Details

IDProjectCategoryView StatusLast Update
0002172Ham Radio DeluxeBugpublic2017-08-05 18:27
ReporterPD9FER 
Assigned ToK7ZCZ 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.4.0.671 
Summary0002172: Logbook crashes after 2nd ALE edit
DescriptionWhen editing two qso's in a row logbook crashes.
Steps To ReproduceDouble click any QSO in Logbook to open edit ALE
Click [Lookup] button
After lookup completes, click F7-Save
Double click a second QSO in Logbook
Click [Lookup] button - after a few seconds, Logbook crashes fatally
Additional InformationMinidump included
TagsNo tags attached.
ModuleLogbook
Sub-ModuleALE Window
Testing Not Tested

Relationships

related to 0002165 closedK7ZCZ Logbook stops responding 

Activities

PD9FER

2017-08-01 07:56

viewer  

minidump.rar (402,163 bytes)

K7ZCZ

2017-08-01 10:07

manager   ~0003805

Thanks for providing the minidump. Having a minidump available makes investigating issues like this much easier.

K7ZCZ

2017-08-01 10:10

manager   ~0003807

fixed with this change set: fixed with this change set: https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/3714

g3ucq

2017-08-02 01:07

viewer   ~0003818

Appears fixed but I did get one crash. Sorry the bug dump is so large I chose the wrong save option and could not get the crash to repeat.

g3ucq

2017-08-02 01:12

viewer   ~0003822

Dump file

g3ucq

2017-08-02 01:14

viewer   ~0003823

The file is not being uploaded. It is 119Mb zip. Shall I put it in the Dropbox?

WA9PIE

2017-08-02 15:51

administrator   ~0003846

I'm having trouble verifying this one. Looking for further comment from G3UCQ.

g3ucq

2017-08-02 16:10

viewer   ~0003849

Sorry, but this issue seems to be similar to my 2174. Please check my mini dump from issue 2174. That should provide what you need.
HTH

PD9FER

2017-08-03 10:14

viewer   ~0003865

Confirm fix in 669

n4kit

2017-08-03 11:35

viewer   ~0003871

Appears to be resolved in .669. The issue John is describing is similar, but different. According to 2174 notes, Mike has a possible fix for John's issue checked in for the next build.

g3ucq

2017-08-03 15:57

viewer   ~0003878

Following the 'Steps to Reproduce' I had no crash so Fixed.

WA9PIE

2017-08-05 18:13

administrator   ~0003897

All completed during the 670 build/release.

Issue History

Date Modified Username Field Change
2017-08-01 07:56 PD9FER New Issue
2017-08-01 07:56 PD9FER File Added: minidump.rar
2017-08-01 10:07 K7ZCZ Note Added: 0003805
2017-08-01 10:09 K7ZCZ Relationship added related to 0002165
2017-08-01 10:10 K7ZCZ Assigned To => K7ZCZ
2017-08-01 10:10 K7ZCZ Status new => resolved
2017-08-01 10:10 K7ZCZ Resolution open => fixed
2017-08-01 10:10 K7ZCZ Testing => Not Started
2017-08-01 10:10 K7ZCZ Note Added: 0003807
2017-08-01 10:23 K7ZCZ Project 1 - Backlog => 3 - Current Dev List
2017-08-02 01:07 g3ucq Note Added: 0003818
2017-08-02 01:12 g3ucq Note Added: 0003822
2017-08-02 01:14 g3ucq Note Added: 0003823
2017-08-02 07:33 K7ZCZ Fixed in Version => 6.4.0.669
2017-08-02 07:33 K7ZCZ Steps to Reproduce Updated View Revisions
2017-08-02 15:51 WA9PIE Note Added: 0003846
2017-08-02 16:10 g3ucq Note Added: 0003849
2017-08-03 10:14 PD9FER Note Added: 0003865
2017-08-03 11:35 n4kit Note Added: 0003871
2017-08-03 15:57 g3ucq Note Added: 0003878
2017-08-05 18:07 WA9PIE Testing Not Started => Not Tested
2017-08-05 18:09 WA9PIE Fixed in Version 6.4.0.669 => 6.4.0.670
2017-08-05 18:10 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2017-08-05 18:13 WA9PIE Note Added: 0003897
2017-08-05 18:13 WA9PIE Status resolved => closed
2017-08-05 18:27 WA9PIE Fixed in Version 6.4.0.670 => 6.4.0.671