View Issue Details

IDProjectCategoryView StatusLast Update
0002174Ham Radio DeluxeBugpublic2017-08-05 18:27
Reporterg3ucq 
Assigned ToK7ZCZ 
PrioritynormalSeveritycrashReproducibilityrandom
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.4.0.671 
Summary0002174: HThe Logbook stops responding
DescriptionSometimes the Logbook stops responding, usually after entering a QSO in the Logbook ALE window.
Steps To ReproduceThe crash is very random but seems to occur after entering a new QSO in the ALE window and clicking Update.
The QSO appears in the log then I sometimes get a stopped responding message and have to close the Logbook.
I hope the minidump helps you.
TagsNo tags attached.
ModuleLogbook
Sub-ModuleALE Window
Testing Not Tested

Relationships

Activities

g3ucq

2017-08-02 08:59

viewer  

HRDLogbook.dmp (227,576 bytes)

K7ZCZ

2017-08-03 01:12

viewer   ~0003863

Thanks for the dump. Having a minidump makes investigating problems possible, and usually successful -- without a dump, unless the issue is pretty obvious from static analysis of the code, it's a difficult path.

In this case, even with a dump, there's a bit of trouble. I can see where the crash is specifically happening, but I'm not positive I can make a complete fix in one shot. The state I'm seeing in the dump indicates that we're shutting down the ALE window but still want to process a bit of work for it. I can't quite figure why that work is being processed, and there seems to be a fragile dance around maintaining some state for lookups which might be happening in the window. It's not clear why any lookups would be processed during shutdown, but that's what the code says.

The fix I've made will appear in the next build after 669. We might have reduced the chances of hitting the crash, might have made no difference, or might have cured the issue. You'll have to tell me -- feel free to submit another dump if the same issue keeps happening.

The current changes just make defensive some code which executes after a dodgy bit of synchronization code:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/3718

g3ucq

2017-08-03 17:00

viewer   ~0003884

Just had another Logbook crash after entering one QSO in the ALE window.
Minidump attached.

HRDLogbook-2.dmp (200,573 bytes)

g3ucq

2017-08-03 17:01

viewer   ~0003885

Using v669

g3ucq

2017-08-05 10:33

viewer   ~0003891

Using v670.
Have now entered about 20 QSOs into my 8,000 QSO log without a problem.
Sorted columns, prssed the Lookup button etc. No problems at all.
I also entered 6 QSOs into a 62,000 QSO log without a problem.
Fixed for me.

K7ZCZ

2017-08-05 12:03

viewer   ~0003892

Awesome. Thanks for testing, and thanks for remembering to update this issue with your observations :)

g3ucq

2017-08-05 14:36

viewer   ~0003893

I am delighted I was able to provide some help in solving the problem and keep HRD moving forward.

WA9PIE

2017-08-05 18:13

administrator   ~0003896

All completed during the 670 build/release.

Issue History

Date Modified Username Field Change
2017-08-02 08:59 g3ucq New Issue
2017-08-02 08:59 g3ucq File Added: HRDLogbook.dmp
2017-08-03 01:12 K7ZCZ Note Added: 0003863
2017-08-03 17:00 g3ucq File Added: HRDLogbook-2.dmp
2017-08-03 17:00 g3ucq Note Added: 0003884
2017-08-03 17:01 g3ucq Note Added: 0003885
2017-08-04 21:33 K7ZCZ Assigned To => K7ZCZ
2017-08-04 21:33 K7ZCZ Status new => assigned
2017-08-04 21:33 K7ZCZ Project 1 - Backlog => 3 - Current Dev List
2017-08-05 10:33 g3ucq Note Added: 0003891
2017-08-05 12:03 K7ZCZ Note Added: 0003892
2017-08-05 12:04 K7ZCZ Status assigned => resolved
2017-08-05 12:04 K7ZCZ Resolution open => fixed
2017-08-05 12:04 K7ZCZ Fixed in Version => 6.4.0.670
2017-08-05 12:04 K7ZCZ Testing => Not Started
2017-08-05 14:36 g3ucq Note Added: 0003893
2017-08-05 18:07 WA9PIE Testing Not Started => Not Tested
2017-08-05 18:10 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2017-08-05 18:13 WA9PIE Note Added: 0003896
2017-08-05 18:13 WA9PIE Status resolved => closed
2017-08-05 18:27 WA9PIE Fixed in Version 6.4.0.670 => 6.4.0.671