View Issue Details

IDProjectCategoryView StatusLast Update
0002175Ham Radio DeluxeBugpublic2018-03-04 15:16
Reporterg3ucq 
Assigned ToK7ZCZ 
PriorityhighSeveritymajorReproducibilitysometimes
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.4.0.794 
Summary0002175: Logbook Filter options either do not appear or take a long time to appear
DescriptionLogbook Filter options either do not appear or take a long time to appear
Steps To ReproduceEnter 2 QSOs in the Logbook ALE window.
When they show in the log, click on the Filter button.
The Filter options either take a long time to load or do not load at all.
At this time. clicking the Logbook shut down X means the Logbook takes many seconds to close, if at all.
This could be related to the overall Logbook response problems.
Because the Logbook has not actually crashed there is no mini dump for you.
TagsNo tags attached.
ModuleLogbook
Sub-ModuleGeneral
TestingNot Started

Relationships

Activities

g3ucq

2017-08-02 16:38

viewer  

Capture.JPG (69,465 bytes)
Capture.JPG (69,465 bytes)

g3ucq

2017-08-05 16:06

viewer   ~0003894

After using the Logbook/Filter/Callsign option to edit some QSOs, the Logbook does not stop responding.
The logbook just takes a long time to refresh.
Wait a good few seconds and eventually the filter will appear in the empty part of the capture.jpg.

g3ucq

2017-08-10 15:59

viewer   ~0003960

v777 seems to have this problem fixed. I cannot now reproduce the results I had before.
The filter works as it should. Fast and smooth.

K7ZCZ

2017-09-22 15:01

manager   ~0004261

This was addressed by adding the "Apply" button and removing the timer from the logbook filter feature.

g3ucq

2017-12-09 05:38

viewer   ~0004285

Search is very fast but opening and closing take a few seconds. There seems to be an update to the logbook.

g3ucq

2018-02-23 03:53

viewer   ~0004318

On the first Filter operation the response is quite quick but later Filter operations take a while for the Filter options to appear.
The Logbook can show 'stop responding' at this time.
Even though no changes have been made while the Filter is open, on closing something seems to be written to the Logbook.
I would also like to have the Return key added as well as the APPLY button. Mike K7ZCZ said that would be difficult to implement but that function used to be available.

g3ypp

2018-02-28 06:39

viewer   ~0004329

The Filter Options area does not resize/adjust automatically so it is easy to cover the Apply button if the Cluster band map is open.

g3ypp

2018-03-01 04:46

viewer   ~0004336

This is what I mean by the filter "Apply" button being hidden. The Cluster band map (locked in) covers it up. See attached pic

The main command bar above the filter options auto resizes and adjusts to 2 lines when the cluster band map is opened so you don't lose any buttons.
The Filter options bar does not resize and adjust so the apply button is covered over.

Apply_button_hidden.PNG (72,941 bytes)
Apply_button_hidden.PNG (72,941 bytes)

g3ypp

2018-03-04 04:39

viewer   ~0004433

.793 has resolved this issue. The apply button is now visible with the Cluster Band Plan pane open.

WA9PIE

2018-03-04 10:39

administrator   ~0004440

FWIW - a number of people are unhappy about the "Apply" button. They liked it the way it was. As for me, I love the apply button.

This may be one of those things that we give them an option for by putting a radio button or check box under the apply button.

But as it is, this one is resolved... closing.

Issue History

Date Modified Username Field Change
2017-08-02 16:38 g3ucq New Issue
2017-08-02 16:38 g3ucq File Added: Capture.JPG
2017-08-05 16:06 g3ucq Note Added: 0003894
2017-08-10 15:59 g3ucq Note Added: 0003960
2017-09-22 15:01 K7ZCZ Assigned To => K7ZCZ
2017-09-22 15:01 K7ZCZ Status new => resolved
2017-09-22 15:01 K7ZCZ Resolution open => fixed
2017-09-22 15:01 K7ZCZ Testing => Not Started
2017-09-22 15:01 K7ZCZ Note Added: 0004261
2017-09-25 12:54 WA9PIE Project 1 - Backlog => 3 - Current Dev List
2017-12-07 14:13 Roger Fixed in Version => 6.4.0.788
2017-12-09 05:38 g3ucq Note Added: 0004285
2018-02-23 03:53 g3ucq Note Added: 0004318
2018-02-28 06:39 g3ypp Note Added: 0004329
2018-03-01 04:46 g3ypp File Added: Apply_button_hidden.PNG
2018-03-01 04:46 g3ypp Note Added: 0004336
2018-03-04 04:39 g3ypp Note Added: 0004433
2018-03-04 10:39 WA9PIE Note Added: 0004440
2018-03-04 10:40 WA9PIE Status resolved => closed
2018-03-04 14:15 WA9PIE Fixed in Version 6.4.0.788 => 6.4.0.794
2018-03-04 15:16 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe