View Issue Details

IDProjectCategoryView StatusLast Update
0002179Ham Radio DeluxeBugpublic2017-09-18 00:08
ReporterPD9FER 
Assigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityrandom
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.4.0.787 
Summary0002179: HRD Sattrack gives unexpected error on exit
DescriptionWhen running Rig Control, HRD Rotator and HRD Sattrack, closing Sattrack I receive an Unexpected error
Observed in Build 669 and happens at random/
Steps To ReproduceStart Rig Control
Start Rotator
Start Sattrack and enable tracking (see Tools > Options > Rotator Help for setting up)
While tracking a Satellite, Exit Sattrack
 
Additional InformationMinidump added
TagsNo tags attached.
ModuleSatellite Tracking
Sub-ModuleRotators
TestingNot Started

Relationships

Activities

PD9FER

2017-08-03 17:38

viewer  

Sattrack build 669 minidump.rar (287,545 bytes)

K7ZCZ

2017-08-19 16:46

manager   ~0004059

> HRDSatTrack.exe!CMainFrame::DDECallback(unsigned short wType=16400, unsigned short wFmt=1, HCONV__ * hConv=0x03000981, HSZ__ * hsz1=0x0000c002, HSZ__ * hsz2=0x0000c003, HDDEDATA__ * hData=0x73001301, unsigned long dwData1=0, unsigned long dwData2=0) Line 3720 C++
     [External Code]
     HRDSatTrack.exe!AfxInternalPumpMessage() Line 183 C++
     HRDSatTrack.exe!AfxWinMain(HINSTANCE__ * hInstance=0x00000000, HINSTANCE__ * hPrevInstance=0x00000020, wchar_t * lpCmdLine=0x00000001, int nCmdShow=2029704) Line 47 C++
     [External Code]

K7ZCZ

2017-08-19 16:51

manager   ~0004060

The stack shows that a DDE message is received when the MainFrame window has already closed. MainFrame() returns a NULL reference; that reference is de-referenced to chase down a member variable, and the app dies.

K7ZCZ

2017-08-19 18:42

manager   ~0004062

I am not able to reproduce the problem because of unclear and incomplete instructions in the repro steps.

However, given the minidump file, I believe I've made a reasonable fix. If the issue persists, please provide revised steps to exercise the issue.

K7ZCZ

2017-08-19 18:43

manager   ~0004063

I think I've got a fix with this changeset:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/3787

WA9PIE

2017-09-18 00:08

administrator   ~0004219

Closed as part of the 6.4.0.787 release.

Issue History

Date Modified Username Field Change
2017-08-03 17:38 PD9FER New Issue
2017-08-03 17:38 PD9FER File Added: Sattrack build 669 minidump.rar
2017-08-19 16:46 K7ZCZ Note Added: 0004059
2017-08-19 16:51 K7ZCZ Note Added: 0004060
2017-08-19 18:42 K7ZCZ Note Added: 0004062
2017-08-19 18:43 K7ZCZ Assigned To => K7ZCZ
2017-08-19 18:43 K7ZCZ Status new => resolved
2017-08-19 18:43 K7ZCZ Resolution open => fixed
2017-08-19 18:43 K7ZCZ Testing => Not Started
2017-08-19 18:43 K7ZCZ Note Added: 0004063
2017-08-29 18:19 K7ZCZ Project 1 - Backlog => 3 - Current Dev List
2017-09-01 16:41 K7ZCZ Fixed in Version => 6.4.0.782
2017-09-07 18:18 K7ZCZ Fixed in Version 6.4.0.782 => 6.4.0.784
2017-09-11 21:32 K7ZCZ Fixed in Version 6.4.0.784 => 6.4.0.785
2017-09-14 19:23 K7ZCZ Fixed in Version 6.4.0.785 => 6.4.0.787
2017-09-18 00:06 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2017-09-18 00:08 WA9PIE Note Added: 0004219
2017-09-18 00:08 WA9PIE Status resolved => closed