View Issue Details

IDProjectCategoryView StatusLast Update
0002185Ham Radio DeluxeEnhancementpublic2017-08-15 22:39
ReporterPD9FER 
Assigned ToK7ZCZ 
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.4.0.780 
Summary0002185: Add FT8 Mode to standard Mode list in Logbook
DescriptionAt this moment there is no FT8 in the logbook Mode list.
Request to add it.
Steps To ReproduceN/A
Additional Informationhttps://support.ham-radio-deluxe.com/scp/tickets.php?id=11010
TagsNo tags attached.
ModuleLogbook
Sub-ModuleGeneral
Testing Beta Successful

Relationships

Activities

K7ZCZ

2017-08-06 16:45

manager   ~0003926

More information is needed. For example: how does this new mode participate in award tracking?

WA9PIE

2017-08-13 22:10

administrator   ~0003969

Last edited: 2017-08-13 22:15

View 3 revisions

Doing some testing to determine the impact of adding a mode to import/export.

While you can only create QSOs with modes that are included in HRD...

The bottom line is - Logbook doesn't do any mode validation on import or export. You could literally create a QSO for any fictitious mode and import it into HRD Logbook and it will import without error or modification. Likewise, you can export the same QSO with a fictitious mode and it will export correctly. (I created the ADIF file for import from another program... and I read the exported file with a text editor.)

The fictitious mode correctly shows up in the digital modes awards tally because it is neither CW nor Phone (which is how the award is designed).

These tests indicates that it is harmless to add modes. And... several are missing - besides FT8.

I'll work on the XML for these.



Junkmode.png (64,467 bytes)
Junkmode.png (64,467 bytes)

WA9PIE

2017-08-13 23:50

administrator   ~0003970

I've updated these files for the modes that are missing in HRD from those in the ADIF Modes enumeration.

LogbookModes.xml (5,439 bytes)
ClientLogbookRSTValues.xml (2,174 bytes)

K7ZCZ

2017-08-14 00:50

manager   ~0003971

With this change set, RST for a handful of digital modes (including FT8) are added, and 18 more modes are added:

https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/3762

K7ZCZ

2017-08-14 22:46

manager   ~0003975

Added default values for RST for those digital modes in this change set:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/3764

WA9PIE

2017-08-15 22:39

administrator   ~0003987

Tested and good to go!

Issue History

Date Modified Username Field Change
2017-08-06 12:52 PD9FER New Issue
2017-08-06 16:44 K7ZCZ Project 1 - Backlog => 3 - Current Dev List
2017-08-06 16:45 K7ZCZ Note Added: 0003926
2017-08-13 22:10 WA9PIE File Added: Junkmode.png
2017-08-13 22:10 WA9PIE Note Added: 0003969
2017-08-13 22:12 WA9PIE Note Edited: 0003969 View Revisions
2017-08-13 22:15 WA9PIE Note Edited: 0003969 View Revisions
2017-08-13 23:50 WA9PIE File Added: ClientLogbookRSTValues.xml
2017-08-13 23:50 WA9PIE File Added: LogbookModes.xml
2017-08-13 23:50 WA9PIE Note Added: 0003970
2017-08-13 23:51 WA9PIE Assigned To => K7ZCZ
2017-08-13 23:51 WA9PIE Status new => assigned
2017-08-14 00:50 K7ZCZ Status assigned => resolved
2017-08-14 00:50 K7ZCZ Resolution open => fixed
2017-08-14 00:50 K7ZCZ Testing => Alpha Failed
2017-08-14 00:50 K7ZCZ Note Added: 0003971
2017-08-14 22:46 K7ZCZ Note Added: 0003975
2017-08-14 23:33 K7ZCZ Fixed in Version => 6.4.0.779
2017-08-14 23:33 K7ZCZ Testing Alpha Failed => Not Started
2017-08-15 22:38 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2017-08-15 22:38 WA9PIE Testing Not Started => Beta Successful
2017-08-15 22:39 WA9PIE Fixed in Version 6.4.0.779 => 6.4.0.780
2017-08-15 22:39 WA9PIE Note Added: 0003987
2017-08-15 22:39 WA9PIE Status resolved => closed