View Issue Details

IDProjectCategoryView StatusLast Update
0002224Ham Radio DeluxeBugpublic2018-04-09 14:37
ReporterKB3NPH 
Assigned ToK7ZCZ 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.4.0.806 
Summary0002224: PSK Reporter - Browser Incompatible
DescriptionTicket# 208805
When I open the PSK reporter in DM780 this is what I see at the top of the page
"You are using a browser that is not supported by the Google Maps JavaScript API.
Steps To ReproduceConfirmed:
Open DM-780.
Open Program Options
Select PSKReporter and display map

See attached image.

Browser incompatibility in the HRD I.E. Browser has been an issue for quite some time with many websites. We have been told that the Java Script does not work with the DLL shell used for the browser in the HRD software.

TagsNo tags attached.
ModuleAll
Sub-ModuleAppearance/UI
Testing Beta Successful

Relationships

has duplicate 0002318 closedK7ZCZ Make choice to use internal or external browser 

Activities

KB3NPH

2017-08-21 07:49

administrator  

PSKReporter 640-780.jpg (243,443 bytes)
PSKReporter 640-780.jpg (243,443 bytes)

PD9FER

2017-08-21 07:54

viewer   ~0004065

Confirmed in Build 780

PD9FER

2018-01-04 08:49

viewer   ~0004297

Ticket #990624

PD9FER

2018-01-05 04:47

viewer   ~0004298

Ticket #303941

PD9FER

2018-02-13 06:19

viewer   ~0004312

Ticket #907601
Same goes for Logbook QRZ pages on some systems

K7ZCZ

2018-03-24 11:13

manager   ~0004558

I looked into this.

Three apps (Digital Master, Logbook, SatTracker) all have browser windows. Of course, the code is copy-pasta and not reused. Fortunately, it doesn't seem like there's a ton of deviation between the versions.

1) HRD uses the WebBrowser control in a few places. I've found some documentation, but nothing perscriptive. Looks like a host of the control can implement a few extra interfaces (like IInternetSecurityManager) to override security settings and allow scripted and active content. I've tried a sample app to see if I can make it work, and I'm not meeting with any success. With no clear docs, it's somewhere between a research project and a guessing game.

2) We can look at hosting Chrome. The Chromium Embedding Kit is well-supported and well-documented; it requires building external code and carrying it around, installing it, and upgrading it every once in a while. The Chromium Kit includes Crash Pad, which is Google's crash tracking solution, which could help us manage minidumps. A bunch of work, but a higher liklihood of success compared to hosting IE.

3) We might ditch hosting the web browser in the app. Need to evaluate the value it provides. Looks like low value, and the cost of fixing/maintaining it is pretty high. Opening links outside the app gives the user more control, relieves the app from managing security and integration.

We'll need to maek a design decision about what the best course of action is.

K7ZCZ

2018-03-24 15:16

manager   ~0004561

After a conversation with Mike, we'll remove the web browser tab from the app. Mike checked with some customers and they're all for this change.

For each of the three apps, gotta do this:

1) Remove browser view, frame, tab, doc template
2) Find and remove associated toolbar buttons, menu items, help text
3) Fix/change the application's navigate method to not use the built-in browser tab

Probably some more cleanup than that. But I'll get on it ...

K7ZCZ

2018-03-26 09:02

manager   ~0004581

The internal browser windows have been removed in this checkin.
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4003

vk2byi

2018-04-04 03:50

viewer   ~0004659

Tested opening PSKReporter within DM-780, as well as QRZ.com from right-click context menu in DX Cluster and Logbook grid, and all opened successfully in default Windows browser (Google Chrome in my case). Fixed

k6mkf

2018-04-04 10:21

viewer   ~0004670

v.799 - DM-780 Icons are ascew - incorrect icons on the buttons. Do not match up with v.794.

DM-780 Icons Ascew.JPG (139,893 bytes)
DM-780 Icons Ascew.JPG (139,893 bytes)

PD9FER

2018-04-04 10:55

viewer   ~0004671

Confirming Fixed the PSK reporter issue
Also confirming the Icons are askew in build 799

K7ZCZ

2018-04-04 19:38

manager   ~0004693

re-activated pending fix of icons ...

K7ZCZ

2018-04-04 19:38

manager   ~0004694

remove "fixed in version" pending fix of icons

K7ZCZ

2018-04-04 20:07

manager   ~0004695

Icon issue fixed with this change:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4018

Issue History

Date Modified Username Field Change
2017-08-21 07:49 KB3NPH New Issue
2017-08-21 07:49 KB3NPH File Added: PSKReporter 640-780.jpg
2017-08-21 07:54 PD9FER Note Added: 0004065
2018-01-04 08:49 PD9FER Note Added: 0004297
2018-01-05 04:47 PD9FER Note Added: 0004298
2018-02-13 06:19 PD9FER Note Added: 0004312
2018-03-24 08:36 K7ZCZ Relationship added related to 0002318
2018-03-24 11:13 K7ZCZ Note Added: 0004558
2018-03-24 11:14 K7ZCZ Assigned To => K7ZCZ
2018-03-24 11:14 K7ZCZ Status new => assigned
2018-03-24 15:16 K7ZCZ Note Added: 0004561
2018-03-26 09:02 K7ZCZ Status assigned => resolved
2018-03-26 09:02 K7ZCZ Resolution open => fixed
2018-03-26 09:02 K7ZCZ Note Added: 0004581
2018-03-26 09:03 K7ZCZ Relationship deleted related to 0002318
2018-03-26 09:03 K7ZCZ Relationship added has duplicate 0002318
2018-04-02 10:42 K7ZCZ Project 1 - Backlog => 3 - Current Dev List
2018-04-02 10:45 K7ZCZ Fixed in Version => 6.4.0.798
2018-04-04 03:50 vk2byi Note Added: 0004659
2018-04-04 10:21 k6mkf File Added: DM-780 Icons Ascew.JPG
2018-04-04 10:21 k6mkf Note Added: 0004670
2018-04-04 10:55 PD9FER Note Added: 0004671
2018-04-04 14:54 WA9PIE Status resolved => closed
2018-04-04 14:54 WA9PIE Testing Not Started => Beta Successful
2018-04-04 19:38 K7ZCZ Status closed => assigned
2018-04-04 19:38 K7ZCZ Note Added: 0004693
2018-04-04 19:38 K7ZCZ Fixed in Version 6.4.0.798 =>
2018-04-04 19:38 K7ZCZ Note Added: 0004694
2018-04-04 20:07 K7ZCZ Status assigned => resolved
2018-04-04 20:07 K7ZCZ Testing Beta Successful => Not Started
2018-04-04 20:07 K7ZCZ Note Added: 0004695
2018-04-05 01:40 K7ZCZ Fixed in Version => 6.4.0.800
2018-04-06 11:54 WA9PIE Status resolved => closed
2018-04-06 11:54 WA9PIE Testing Not Started => Beta Successful
2018-04-07 19:23 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2018-04-07 19:26 WA9PIE Fixed in Version 6.4.0.800 => 6.4.0.805
2018-04-09 14:37 WA9PIE Fixed in Version 6.4.0.805 => 6.4.0.806