View Issue Details

IDProjectCategoryView StatusLast Update
0002246Ham Radio DeluxeBugpublic2018-03-04 15:16
ReporterKB3NPH 
Assigned Todoug 
PriorityhighSeveritymajorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.4.0.794 
Summary0002246: Award Tracking shows zeros
DescriptionTicket #840254
Another ticket where the Awards all show as ZERO. Again I tried everything to resolve it but couldn't.
Additional InformationIt appears to be an issue caused by Office 365. This appears to happen if Office 365 is installed prior to installing HRD. Seems in the past a customer resolved his own issue by uninstalling Office 365 and a complete uninstall of HRD. Reinstalled HRD as if a new install, activated it, then rebuilt his log from a backup and the Awards worked. He then re-stalled Office 365 and everything still worked as it should.
TagsNo tags attached.
ModuleLogbook
Sub-ModuleAwards
Testing Beta Successful

Relationships

Activities

KB3NPH

2018-01-17 14:01

administrator   ~0004305

Another customer with same issue: Ticket #378192

KB3NPH

2018-01-18 15:13

administrator   ~0004306

Another customer with same problem Ticket #165680

doug

2018-02-09 23:07

developer   ~0004310

This is a bug in the loggers database code. The code is pretty complicated when it comes to creating the connection string, and making sure there is an Access driver on the machine. One thing it tries to do is latch on to the DSN called "MS Access Database". This is installed with Office, so it was probably used as a known DSN that had an access driver. However, if you have 64-bit Office installed, this driver is 64-bit and will fail from the logger software since it is 32-bit.

One workaround is to just tell the user to delete that ODBC data source from control panel.

I changed up the code so it will not try to keep using the "MS Access Database" DSN if it fails the first time.

This needs to be tested the next time the project is built.

g3ucq

2018-02-23 02:46

viewer   ~0004316

No zeros. Using a MySQL database.

WA9PIE

2018-03-01 23:30

administrator   ~0004343

Doug knocked this one out-of-the-park!

Thanks Doug!

g3ypp

2018-03-04 04:41

viewer   ~0004434

Working for me.

Issue History

Date Modified Username Field Change
2017-09-11 12:55 KB3NPH New Issue
2018-01-17 14:01 KB3NPH Note Added: 0004305
2018-01-18 15:13 KB3NPH Note Added: 0004306
2018-02-09 23:07 doug Note Added: 0004310
2018-02-22 13:03 Roger Assigned To => doug
2018-02-22 13:03 Roger Status new => resolved
2018-02-22 13:03 Roger Resolution open => fixed
2018-02-22 14:00 Roger Project 1 - Backlog => 3 - Current Dev List
2018-02-22 14:02 Roger Fixed in Version => 6.4.0.790
2018-02-23 02:46 g3ucq Note Added: 0004316
2018-03-01 23:30 WA9PIE Testing Not Started => Beta Successful
2018-03-01 23:30 WA9PIE Note Added: 0004343
2018-03-04 04:41 g3ypp Note Added: 0004434
2018-03-04 10:27 WA9PIE Status resolved => closed
2018-03-04 14:15 WA9PIE Fixed in Version 6.4.0.790 => 6.4.0.794
2018-03-04 15:16 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe