View Issue Details

IDProjectCategoryView StatusLast Update
00022533 - Current Dev ListBugpublic2017-09-25 12:54
Reporterg3ucq 
Assigned ToK7ZCZ 
PriorityhighSeveritymajorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0002253: HRD Logbook stops responding
DescriptionI was entering a QSO with the Logbook ALE and got a message saying that Logbook had stopped responding and a dump had been created. It is attached.
Steps To ReproduceLoad HRD, Logbook, DM780 and Rotator.
Add a QSO with the Logbook ALE and rarely the Logbook stops responding.
I can add the dump file this time as it is smaller in size.
TagsNo tags attached.
ModuleLogbook
Sub-ModuleALE Window
TestingNot Started

Relationships

duplicate of 0002199 assignedK7ZCZ 1 - Backlog HRD Logbook stops responding 

Activities

g3ucq

2017-09-19 15:35

updater  

HRDLogbook.exe.2452.zip (1,680,667 bytes)

g3ucq

2017-09-21 00:22

updater   ~0004252

Another Logbook crash but the zipped dump file is too large again.

g3ucq

2017-09-21 13:34

updater   ~0004253

Another crash. This time the VS stepped and created the file

HRDLogbook.zip (23,609 bytes)

K7ZCZ

2017-09-22 14:19

viewer   ~0004259

Both dumps are the same stack trace as Mantis 2199. Unfortunately, I don't detect any new clues here that would help me crack the case.

K7ZCZ

2017-09-22 14:19

viewer   ~0004260

0:000> kp
 # ChildEBP RetAddr
WARNING: Frame IP not in any known module. Following frames may be wrong.
00 0018e934 014c5ee6 0x4
01 0018ec74 00f4408b HRDLogbook!CLogbookFull::OnReset(void)+0x866 [c:\ham radio\logbook\hrdlogbook\logbookfull.cpp @ 6284]
02 0018ec84 00f43ec4 HRDLogbook!_AfxDispatchCmdMsg(class CCmdTarget * pTarget = 0x1a129760, unsigned int nID = 0x4f95, int nCode = 0n0, <function> * pfn = 0x014c5680, void * pExtra = 0x00000000, unsigned int nSig = 0x3a, struct AFX_CMDHANDLERINFO * pHandlerInfo = 0x00000000)+0x42 [f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\cmdtarg.cpp @ 78]
03 0018ecb4 00f545c8 HRDLogbook!CCmdTarget::OnCmdMsg(unsigned int nID = 0x4f95, int nCode = 0n0, void * pExtra = 0x00000000, struct AFX_CMDHANDLERINFO * pHandlerInfo = 0x00000000)+0x120 [f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\cmdtarg.cpp @ 373]
04 0018ecd8 00f3f867 HRDLogbook!CPropertySheet::OnCmdMsg(unsigned int nID = 0x4f95, int nCode = 0n0, void * pExtra = 0x00000000, struct AFX_CMDHANDLERINFO * pHandlerInfo = 0x00000000)+0x1b [f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\dlgprop.cpp @ 816]
05 0018ed28 00f40454 HRDLogbook!CWnd::OnCommand(unsigned int wParam = 0x4f95, long lParam = 0n0)+0x89 [f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\wincore.cpp @ 2784]
06 0018ede0 00f0d4b6 HRDLogbook!CWnd::OnWndMsg(unsigned int message = 0x111, unsigned int wParam = 0x4f95, long lParam = 0n0, long * pResult = 0x0018ee18)+0x3c [f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\wincore.cpp @ 2108]
07 0018edfc 00f41c4a HRDLogbook!CXTPDialogBase<CXTPResizeDialog>::OnWndMsg(unsigned int message = 0x111, unsigned int wParam = 0x4f95, long lParam = 0n0, long * pResult = 0x0018ee18)+0x46 [c:\ham radio\codejock software\mfc\xtreme toolkitpro v15.0.2\source\commandbars\xtpdialogbase.h @ 194]
08 0018ee1c 00f3d2bd HRDLogbook!CWnd::WindowProc(unsigned int message = 0x111, unsigned int wParam = 0x4f95, long lParam = 0n0)+0x22 [f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\wincore.cpp @ 2094]
09 0018ee8c 00f3da72 HRDLogbook!AfxCallWndProc(class CWnd * pWnd = 0x1a129760, struct HWND__ * hWnd = 0x000903bc, unsigned int nMsg = 0x111, unsigned int wParam = 0x4f95, long lParam = 0n0)+0xb0 [f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\wincore.cpp @ 285]
:
:
:

Issue History

Date Modified Username Field Change
2017-09-19 15:35 g3ucq New Issue
2017-09-19 15:35 g3ucq File Added: HRDLogbook.exe.2452.zip
2017-09-21 00:22 g3ucq Note Added: 0004252
2017-09-21 13:34 g3ucq File Added: HRDLogbook.zip
2017-09-21 13:34 g3ucq Note Added: 0004253
2017-09-22 14:19 K7ZCZ Note Added: 0004259
2017-09-22 14:19 K7ZCZ Assigned To => K7ZCZ
2017-09-22 14:19 K7ZCZ Status new => resolved
2017-09-22 14:19 K7ZCZ Resolution open => fixed
2017-09-22 14:19 K7ZCZ Testing => Not Started
2017-09-22 14:19 K7ZCZ Relationship added duplicate of 0002199
2017-09-22 14:19 K7ZCZ Note Added: 0004260
2017-09-25 12:54 WA9PIE Project 1 - Backlog => 3 - Current Dev List