View Issue Details

IDProjectCategoryView StatusLast Update
00022553 - Current Dev ListBugpublic2017-09-25 12:54
ReporterKC7FPF 
Assigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Product Version 
Target VersionFixed in Version 
Summary0002255: Item found in Logbook under the filter function
Descriptionthere is the text 'OK' on the filter form that at does not appear to have a purpose.
TagsNo tags attached.
ModuleLogbook
Sub-ModuleAppearance/UI
TestingNot Started

Relationships

Activities

KC7FPF

2017-09-20 12:47

updater  

K7ZCZ

2017-09-20 20:28

viewer   ~0004251

 The text (in the snapshot) is by design. It changes to a different status message if the filter criteria entered is unusable. For example:

1) Mark the "Callsign" checkbox and no others
2) Make sure the callsign edit field is empty
3) Select "Contains" in the "Match" field

In this state, the "OK" status text changes to "Callsign filter not valid" and the "Apply" button is disabled. This is because searching for a filed that contains an empty string doesn't make sense, and the resulting work would be useless.

You can read more about the recent changes to the Filter feature in this Beta forum thread:
https://forums.ham-radio-deluxe.com/forum/beta-testers-forum/43496-fixes-to-the-filter-feature-of-the-logbook

Issue History

Date Modified Username Field Change
2017-09-20 12:47 KC7FPF New Issue
2017-09-20 12:47 KC7FPF File Added: filter reset needed (1).JPG
2017-09-20 20:28 K7ZCZ Assigned To => K7ZCZ
2017-09-20 20:28 K7ZCZ Status new => resolved
2017-09-20 20:28 K7ZCZ Resolution open => no change required
2017-09-20 20:28 K7ZCZ Sub-Module (select) => Appearance/UI
2017-09-20 20:28 K7ZCZ Testing => Not Started
2017-09-20 20:28 K7ZCZ Note Added: 0004251
2017-09-25 12:54 WA9PIE Project 1 - Backlog => 3 - Current Dev List