View Issue Details

IDProjectCategoryView StatusLast Update
0002604Ham Radio DeluxeEnhancementpublic2018-04-09 14:37
ReporterK7ZCZ 
Assigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version6.4.0.794 
Target VersionFixed in Version6.4.0.806 
Summary0002604: Logbook filter: Provide a filter reset capability to clear all filter fields
DescriptionA button could be added to the filter feature in the logbook that resets the column selections, their values, and operators. This would make moving from one filter activity to the next a little easier.

TagsNo tags attached.
ModuleLogbook
Sub-ModuleFunctional
Testing Beta Successful

Relationships

related to 0002589 closedK7ZCZ Logbook Filter Improvements Needed 

Activities

K7ZCZ

2018-03-22 10:52

manager   ~0004522

This shelved change list is out for review. It adds a "reset" button.

https://hrdsoftware.visualstudio.com/HRD/_versionControl/shelveset?ss=Logbook%20Filter%20bar%20enhancements%2C%20Reload%28%29%20refactor%3Bmikeblas%40msn.com

K7ZCZ

2018-03-23 12:12

manager   ~0004542

Fixed with this checkin, which adds a reset button and some of the required state management. I'll probably tune the state management as I go along ...

https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/3990

g3ucq

2018-04-03 17:11

viewer   ~0004641

The 'reset' button clears the filter fields but not data result displayed.

K7ZCZ

2018-04-03 17:29

manager   ~0004643

That's by design (for now). There are a couple of other bugs in this area, and it wasn't possible to fix them all simultaneously.

w4elp

2018-04-03 18:13

viewer   ~0004646

Reset button working, with Mikes caveat. Nice addition.

vk2byi

2018-04-04 00:42

viewer   ~0004653

I like this new feature. Works well enough without clearing the 'filtered' results, as the next step will most likely be a new set of filter conditions and results, or closing of the filter panel which refreshes 'unfiltered' results.

Issue History

Date Modified Username Field Change
2018-03-18 17:07 K7ZCZ New Issue
2018-03-18 17:20 K7ZCZ Relationship added related to 0002589
2018-03-20 10:55 K7ZCZ Status new => assigned
2018-03-20 10:55 K7ZCZ Assigned To => K7ZCZ
2018-03-22 10:52 K7ZCZ Note Added: 0004522
2018-03-23 12:12 K7ZCZ Status assigned => resolved
2018-03-23 12:12 K7ZCZ Resolution open => fixed
2018-03-23 12:12 K7ZCZ Note Added: 0004542
2018-04-02 10:39 K7ZCZ Fixed in Version => 6.4.0.798
2018-04-03 17:11 g3ucq Note Added: 0004641
2018-04-03 17:29 K7ZCZ Note Added: 0004643
2018-04-03 18:13 w4elp Note Added: 0004646
2018-04-04 00:42 vk2byi Note Added: 0004653
2018-04-04 14:49 WA9PIE Status resolved => closed
2018-04-04 14:49 WA9PIE Description Updated View Revisions
2018-04-04 14:49 WA9PIE Testing Not Started => Beta Successful
2018-04-07 19:23 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2018-04-07 19:25 WA9PIE Fixed in Version 6.4.0.798 => 6.4.0.805
2018-04-09 14:37 WA9PIE Fixed in Version 6.4.0.805 => 6.4.0.806