View Issue Details

IDProjectCategoryView StatusLast Update
0002655Ham Radio DeluxeBugpublic2018-04-09 14:37
ReporterWA9PIE 
Assigned ToK7ZCZ 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version6.4.0.799 
Target VersionFixed in Version6.4.0.806 
Summary0002655: Update country list in source control
DescriptionThe existing country list in the 799 beta build is out-of-date. Please update the files from here:

https://www.ham-radio-deluxe.com/hrdxmlcountries/LogbookCountryDataEx.xml
https://www.ham-radio-deluxe.com/hrdxmlcountries/UniqueCallSignDatabase.xml
Steps To ReproduceBeta team is reporting that Kosovo is being displayed with an out-of-date name.

https://forums.ham-radio-deluxe.com/node/44921
Additional InformationA couple thoughts to ponder...

If there could be a script in the build process that went out to check to see if these files have updated versions on our website, it would save us steps. I'm already keeping the online versions up-to-date. The script could just check that and human effort eliminated.

As a "stretch goal"... these two files are identical and always will be. 'Someone' a while back decided that a separate file was needed. It's a waste of time for no additional gain. If it were possible to just use one file (LogbookCountryDataEx.xml), that would be fantastic.
TagsNo tags attached.
ModuleLogbook
Sub-ModuleData
Testing Beta Successful

Relationships

Activities

WA9PIE

2018-04-04 20:33

administrator   ~0004696

Actually... if we could change the URL for these files to the following:

https://cdn2.ham-radio-deluxe.com/LogbookCountryDataEx.xml
https://cdn2.ham-radio-deluxe.com/UniqueCallSignDatabase.xml

That way they would get served up through the CDN and we could reduce the traffic (and related cost) to UltraCart.

If you do this, let me know. I'll need to make copies that go up there. (and maintain them in both places for a bit)

WA9PIE

2018-04-04 20:40

administrator   ~0004697

I just updated the file (attached) from the 799 build after importing the existing file... then exporting it. They look the same to me.

MikeB, can you take a look?

LogbookCountryDataEx.xml (222,978 bytes)

K7ZCZ

2018-04-04 22:17

manager   ~0004698

The code will now use https://cdn2.ham-radio-deluxe.com/LogbookCountryDataEx.xml only, not UniqueCallsignDatabase.xml, and not the old URL.

I've added the new XML data file provided here to the build.

The build script also gets from the CDN URL. It only ever used the LCDE.xml file.

K7ZCZ

2018-04-04 22:19

manager   ~0004699

Shelved here:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/shelveset?ss=new%20CDN%20URL%20for%20countries%3Bmikeblas%40msn.com

but I ca'nt test it because both of those CDN URLs are 404

K7ZCZ

2018-04-05 01:45

manager   ~0004700

After working through some CDN caching issues, this was checked in:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4019

WA9PIE

2018-04-06 11:09

administrator   ~0004724

Verified. Fixed.

Issue History

Date Modified Username Field Change
2018-04-04 20:15 WA9PIE New Issue
2018-04-04 20:15 WA9PIE Assigned To => K7ZCZ
2018-04-04 20:15 WA9PIE Status new => assigned
2018-04-04 20:33 WA9PIE Note Added: 0004696
2018-04-04 20:40 WA9PIE File Added: LogbookCountryDataEx.xml
2018-04-04 20:40 WA9PIE Note Added: 0004697
2018-04-04 22:17 K7ZCZ Note Added: 0004698
2018-04-04 22:19 K7ZCZ Note Added: 0004699
2018-04-05 01:45 K7ZCZ Status assigned => resolved
2018-04-05 01:45 K7ZCZ Resolution open => fixed
2018-04-05 01:45 K7ZCZ Fixed in Version => 6.4.0.800
2018-04-05 01:45 K7ZCZ Note Added: 0004700
2018-04-06 11:09 WA9PIE Note Added: 0004724
2018-04-06 11:10 WA9PIE Status resolved => closed
2018-04-06 11:10 WA9PIE Testing Not Started => Beta Successful
2018-04-07 19:23 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2018-04-07 19:26 WA9PIE Fixed in Version 6.4.0.800 => 6.4.0.805
2018-04-09 14:37 WA9PIE Fixed in Version 6.4.0.805 => 6.4.0.806