View Issue Details

IDProjectCategoryView StatusLast Update
0000459Ham Radio DeluxeEnhancementpublic2017-05-23 15:23
ReporterW4PC 
Assigned ToWA9PIE 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.2.10.377 
Summary0000459: Several issues in ALE dialog box of Logbook
DescriptionSee attached image of ALE dialog above Logbook window with Callsign Lookup pane.

1. Selection error in Call field ... enter a callsign (e.g.,
IZ2PNT) and Tab to cause lookup ... double-click the Call field to
select it in preparation for typing another call to replace it ...
type another callsign (e.g, KF5SA) ... the first just typed letter
appears and disappears leaving the original call in the field ...
if you continue typing the new letters prepend the orginal call ...
also, after entering a callsign, double-click and press Del to
delete the callsign, it blinks and reappears ...

2. Several timing issues ... I entered IZ2PN paused briefly and
entered 'T' ... the lookup on the Worked tab remained 'IZ2PN' only
without the 'T' ... trying to do the lookup based on timing AND
looking for Tab apparently causes timing problems ... best to just
require Tab or something more reliable than timing ...

3. Clicking the 'QRZ' button does not display the QRZ Web page as
it does everywhere else in HRD (e.g., QRZ button in Lookup pane,
DM780, etc.). The mouse-over help says it does a Callsign Lookup
but it doesn't do that either as the Callsign Lookup pane in the
Logbook window under this modal dialog box never changes when the
'QRZ' button is pressed. Since it's a modal dialog box it is
logically "attached" to its parent window and should therefore have
a tight relationship to it ... i.e., it should change the Callsign
Lookup pane in its parent window. At a minimum please rename it and clarify its function in the mouse-over help.
TagsNo tags attached.
ModuleLogbook
Sub-Module(select)
Testing

Relationships

Activities

WA9PIE

2014-10-15 08:43

administrator   ~0000572

Clicking the QRZ button in the ALE was never intended to open a browser to QRZ. This isn't a bug. This is an enhancement request.

WA9PIE

2016-12-03 21:57

administrator   ~0003051

Changing to enhancement request. Closing. Denied. Folks can click the QRZ button in the lookup pane to do the same thing. It's not worth the trouble.

WA9PIE

2016-12-03 21:58

administrator   ~0003052

No plans to do this.

Issue History

Date Modified Username Field Change
2013-12-21 18:56 W4PC New Issue
2013-12-21 18:58 W4PC Project 2 - Next Dev List (Holding Area) => @5@
2014-01-31 18:04 WA9PIE Release => (select)
2014-01-31 18:04 WA9PIE Module => (select)
2014-01-31 18:04 WA9PIE Sub-Module => (select)
2014-01-31 18:04 WA9PIE Report Build => (select)
2014-01-31 18:04 WA9PIE Status new => acknowledged
2014-02-02 14:49 WA9PIE Summary Several issues in ALE dialog box of Logbook => Bug: Several issues in ALE dialog box of Logbook
2014-10-15 08:43 WA9PIE Note Added: 0000572
2015-09-17 13:02 WA9PIE Module (select) => Logbook
2015-09-17 13:17 WA9PIE Category Logbook => Bug
2015-09-17 13:19 WA9PIE Project @5@ => 1 - Backlog
2015-09-29 16:27 WA9PIE Fix Build => (select)
2015-09-29 16:27 WA9PIE Summary Bug: Several issues in ALE dialog box of Logbook => Several issues in ALE dialog box of Logbook
2016-12-03 21:56 WA9PIE Reported in Release (select) => 6.3
2016-12-03 21:56 WA9PIE Reported in Build (ie. 377) (select) => 377
2016-12-03 21:57 WA9PIE Fixed in Build (ie. 377) (select) => 377
2016-12-03 21:57 WA9PIE Note Added: 0003051
2016-12-03 21:57 WA9PIE Category Bug => Enhancement
2016-12-03 21:58 WA9PIE Note Added: 0003052
2016-12-03 21:58 WA9PIE Status acknowledged => closed
2016-12-03 21:58 WA9PIE Assigned To => WA9PIE
2016-12-03 21:58 WA9PIE Resolution open => fixed
2017-03-08 19:03 WA9PIE Project 1 - Backlog => Ham Radio Deluxe
2017-05-21 23:38 WA9PIE Fixed in Version => 6.2.10.377
2017-05-21 23:39 WA9PIE Fixed in Build (ie. 377) 377 =>
2017-05-23 15:23 WA9PIE Severity minor => feature