View Issue Details

IDProjectCategoryView StatusLast Update
0000562Ham Radio DeluxeBugpublic2018-04-09 14:37
ReporterW4PC 
Assigned ToK7ZCZ 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
PlatformIntelOSWindows7OS VersionUltimate 32 bit
Product Version 
Target VersionFixed in Version6.4.0.806 
Summary0000562: HRD rig control, "ALT" button does not work with Kenwood TS-2000
DescriptionThe "ALT" button on the TS-2000 rig control screen does not do anything. It should lock the tuning of the TS-2000 where you can NOT change frequency. The same as pressing "FUNC" then "ATT" keys on the front panel of the TS-2000.
Steps To ReproduceJust click on the "ALT" button and see is does not work.
Additional InformationThe command for this function is LK11; I have checked this with the CAT Command Tester and it works. The command to turn this off is LK01; which also works with the command tester. Now making this button press ON, press OFF is up to the programmers. If that is not possible then there would need to be a "ALT OFF" button programmed for the TS-2000 and I assume some other Kenwood rig setups.
TagsKenwood, TS2000
ModuleRig Control
Sub-ModuleRadio Support
Testing Not Tested

Relationships

Activities

K7ZCZ

2018-03-25 19:54

manager   ~0004573

The claims made in this issue aren't correct; the bug reporter is confusing two features. A third feature is involved in the fix.

The "ALT" button doesn't lock anything, though it stands for "Auto Lock Tuning". (Page 72 of the manual.) ALT is used on the 1.2 GHz band to auto-tune signals from radios that aren't so stable. This doesn't lock tuning. This looks like it's correctly wired-up; the commands are LT1 (on) and LT0 (off).

From the manual (page 77) FUNC + ATT on the front panel of the radio puts the radio into frequency lock mode. That locks only the frequency (VFO), not The CAT command for that is LK10 (on) and LK00 (off)

Page 77 also explains that FUNC + PRE on the radio will make lock all mode. That locks everything; VFO and all the other mode buttons are locked. CAT for this is LK20 (on) and LK00 (off).

This issue asks for a lock function, and that is missing. I've added "LockA" and "LockF" buttons. The ATT feature works correctly are doesn't need to be changed.

K7ZCZ

2018-03-29 11:01

manager   ~0004594

Fixed with this change set.
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/3998

Issue History

Date Modified Username Field Change
2013-12-21 18:56 W4PC New Issue
2013-12-21 18:57 W4PC Project 2 - Next Dev List (Holding Area) => @6@
2014-01-31 00:31 WA9PIE Project @6@ => @5@
2014-01-31 07:50 WA9PIE Release => (select)
2014-01-31 07:50 WA9PIE Module => (select)
2014-01-31 07:50 WA9PIE Sub-Module => (select)
2014-01-31 07:50 WA9PIE Report Build => (select)
2014-01-31 07:50 WA9PIE Category Logbook => Rig Control
2014-01-31 18:24 WA9PIE Status new => acknowledged
2014-01-31 18:24 WA9PIE Project @5@ => @6@
2014-02-02 15:04 WA9PIE Summary HRD rig control, "ALT" button does not work with Kenwood TS-2000 => Enhancement: HRD rig control, "ALT" button does not work with Kenwood TS-2000
2015-09-17 13:09 WA9PIE Module (select) => Rig Control
2015-09-17 13:18 WA9PIE Category Rig Control => Enhancement
2015-09-17 13:18 WA9PIE Project @6@ => 1 - Backlog
2015-09-29 17:16 WA9PIE Fix Build => (select)
2015-09-29 17:16 WA9PIE Summary Enhancement: HRD rig control, "ALT" button does not work with Kenwood TS-2000 => HRD rig control, "ALT" button does not work with Kenwood TS-2000
2017-07-15 21:40 K7ZCZ Tag Attached: Kenwood
2017-07-15 21:40 K7ZCZ Tag Attached: TS2000
2018-03-25 18:36 K7ZCZ Assigned To => K7ZCZ
2018-03-25 18:36 K7ZCZ Status acknowledged => assigned
2018-03-25 19:54 K7ZCZ Note Added: 0004573
2018-03-29 11:01 K7ZCZ Status assigned => resolved
2018-03-29 11:01 K7ZCZ Resolution open => fixed
2018-03-29 11:01 K7ZCZ Sub-Module (select) => Radio Support
2018-03-29 11:01 K7ZCZ Testing => Not Started
2018-03-29 11:01 K7ZCZ Note Added: 0004594
2018-04-02 10:44 K7ZCZ Project 1 - Backlog => 3 - Current Dev List
2018-04-02 10:45 K7ZCZ Fixed in Version => 6.4.0.798
2018-04-04 14:39 WA9PIE Category Enhancement => Bug
2018-04-07 19:21 WA9PIE Status resolved => closed
2018-04-07 19:21 WA9PIE Testing Not Started => Not Tested
2018-04-07 19:23 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2018-04-07 19:25 WA9PIE Fixed in Version 6.4.0.798 => 6.4.0.805
2018-04-09 14:37 WA9PIE Fixed in Version 6.4.0.805 => 6.4.0.806